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CHAPTER 1: Introduction to Computer  
 

1.0 INTRODUCTION  

A Computer is an electronic device, which is used for a number of applications ranging from writing letters to reserve a ticket  

in a train. A Computer has several components like Keyboard, Mouse, Processor, Memory, Monitor and printer etc. 

Computer requires instructions to perform a particular task, a series of instructions is normally known as a program. 

Hardware and Software are the two terms we frequently use with reference to Computer. C.P.U. memory and peripheral 

devices (Input and output devices) are generally referred to as Hardware whereas complier, interpreter and operating system 

are examples of software.  

1.1 OBJECTIVES  
After going through this chapter, you will be able to :     

List the various characteristics of a Computer,  

1 Describe the various components of a Computer,  

2 Different types of Computers,  

3 Distinguish between Hardware and Software.  

1.2 COMPUTER AND ITS APPLICATIONS  

Computer derives its name from the word Compute that means calculation. It can be said that Computer Is a device used for 

calculation. Now a days Computer is not only limited to computation, but also used for making phone calls, maintain ing 

databases, listening songs, viewing movies etc. so a more formal definit ion of Computer is required. Computer is an 

electronic device that processes or transforms data into useful Informat ion by executing a series of predefined instructions.  

Flgure1 s hows the basic organization of a Computer. It perfor ms  four basic functions.  

Input  - To perform computation Computer requires input of data from users. The data is entered using an input device, such 

as a keyboard or mouse.  

Processing Unit - The Computer processes the data according to a set of instructions called program.  

Output  ï The Computer returns the processing informat ion in a form that can be used by the user. The informat ion is 

printed, displayed or reported using some type of output device like printer or monitor.

Memory ï Computer saves the data or instructions for future retrieval. 

 

1.2.1 Characteristics of Computer System  
 

Speed ï Computer can do any job electronically much faster than we can do them by hand. For example, in the matter of 

speed of calculations, computers are far ahead of us. The speed of Computer has helped us to solve problems in mathematics 

or Physics that are very large and complex in nature. The central processor unit executes the instructions to solve problems. It  

can execute a billion or more instructions in one second. Present day popular CPU is Pentium 4 that operates at 2.2 GHz. It  

indicates that this processor can execute a simple instruction such as addition in ½.2x109 second i.e. 0.49x10
-9

 second or 0.45 

nano second or in the billionth part of a second. 

 
Accuracy and consistency: Computers never make mistakes In processing. It sometimes produces wrong results 'but In 
almost all such cases It Is the human component that fails through wrong procedures, faulty programs or errors in input . 
There is consistency; i.e., they always get the same results from the same data  
 
Diligence: Computer can perform repetit ive task without getting bored or distracted as a result of which it can work for 
hours together without creating any error and without grumbling. 
  

Storage Capacity:  They can store large amount of information. For example, they can store several encyclopedias. What 

is more, every p iece of  informat ion can be retained as long as desired by the user end can be recalled as and when required.  

 

Inability  to think: Unlike human being, Computers cannot think or act on its own. Necessary instructions need to be 

given to get the desired result.  

 

Inability  to emote: Computer being a machine does not have any emotions or feelings. 

On the basis of the above characteristics, we can say that a Computer differs from all other machines in its generality. It is 

capable of solving any problem, provided the rules and formulae for solving that problem are clearly specified.  

1.2.2 Basic Applications of Computer System  
 
Computers have brought major Changes in Industry, government, education, medicine, scientific research, law, social 

sciences, and even in music and painting. They are used, among other applications, in fo llowing: 
 
Education: Computer is increasingly being used as a resource in teaching and learning at all levels o f education. The 

learning process can be enriched in many subjects because of the scale and range of informat ion provided by the computer 

data banks. Knowledge can be extended by the ability of Computer to carry out lengthy and complex calculat ions at great 

speed. Multimedia and animat ion are extensively being used to teach complex subjects. Computer based training is an easy 

way of learn ing. In addition computers are used as training aid in industry, business and commerce, and to help train people 
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on computer usage and provide practice on computer packages  

 
Libraries and Museums: Computers are nowadays performing most of the jobs in library organizat ions. Lists of 

borrowed books are maintained by the system end reminders for those, which are overdue, can be generated by computerôs 

output. A tally of the number o f times books that are taken out can be kept. Museums also make use of computers to help 

with cataloguing and indexing. Informat ion about the exhib its in a museum's collection is assembled and retained as a large 

database, and Informat ion retrieval capability of the computer can then be exp loited to the benefit of staff and visitors. 

  

Scienti fic Research: Computers are now a standard feature of life in universities and Industrial laboratories and as we have 

seen, there are worldwide networks (internet) linking universities and scientific establishments. Recently there has been an 

increasing use of computers for resear ch and data analysi s in less Mathemat ical areas such as medicine, the social sciences and 

even the humanities. Almost every branch of science and eng ineering has benefited from their development.  

 

Business Applications : The first non-scientific use o computers concerned routine clerical work. Computer applications to 

business and commerce date from the middle of the 1950ôs. The pace of the technology has since quickened and today most 

large and medium-sized companies are almost totally dependent on their computers tor administrative functions. Personal 

computers and internet has brought revolution even in smaller concerns. Payroll accounting, employee management systems, 

material manage ment and nowadays ERP are the app licat ions used in business. Stock control, processing of the sales 

orders and sales accounting, sales analysis, market research, forecasting and subsequent production plann ing ere all areas 

in which the computer helps in business and commercial organizations. In all these cases the company can benefit from the 

immediate availability of information, which the computer provides. 

  

Office Automation : Init ially it was thought at changes in office operation involving computers would be limited to clerical 

and routine functions which are o f a repetitive nature. In the event, the technology and the science of computing advanced 

more rap idly than the business world. Office automation can briefly be defined as the application of today's technology to 

today's office practice. The development of the humble typewriter and the introduction of the adding machine are examples 

of office automat ion from an earlier era. Today, office automat ion covers the use of word processors, personal computers, 

workstations, terminals, various peripheral equipment, networks and FAX systems. It embraces s document preparation, 

desktop publishing, electronic mail, document storage and retrieval, data and voice communicat ion, business packages and 

informat ion management.  

  

Word Processing: Word processors are particularly useful for preparing reports that may need to go through one or more 

revisions and for producing standard letters and documents. The software provides the capability to insert or delete words, 

lines or paragraphs, and to print out drafts and final copies at speed. No matter how many revisions are required the full text  

is only typed in once, i.e. the ini tial draft. Systems may include special purpose  packages for special applications such as 

merging address lists, producing a range documents for quotations, purchase orders and invoices, and very usefully, 

dictionary packages which signal and correct spellings.  

 

Desktop Publishing: Desktop Publishing is a major growth area in the field of office automation. By desktop publishing, 

we mean the process of producing any published material in an office environment from the creation of the text (word and 

graphics) through to page layout and design, and the production of the camera-ready copy complete with artwork.  
 
A desktop publishing system is built around three components: a Computer, page designing software and a printer. The 

software offers a range of fonts and character sizes, handles text justification, embeds graphics into the text and provides 

powerful edit ing features, which permit changes to be made even at the page layout stage. The ability to zoom into any part 

of a page and to enlarge the selected area on the screen is typical of most systems. The most commonly used DTP packages 

are Corel Draw, Ventura, Page Maker etc. 

  

Banking: Banks were among the first large organizations to invest heavily in computing, and today banking is almost totally 

dependent on the computer. Under computer control, customer statements are prepared and printed out onto specially  

designed stationery. Cheques are handled by computers at the clearing banks. The cheques are sorted into branch and then 

customer order and returned to the branches the next day. Developments such as the Automatic Teller Machine (ATM) 

Internet banking, Phone banking are making it even easier for customers to deal with banks. 

  

Reservation Systems: Computerized seat reservation brings benefit to customers and to the airlines and Railways. 

Computer controlled reserv at ions are also applicable to t ravel agents, hotel rooms, theatre seat, and sports events at large 

stadiums.  
 
Air traffic Control : Air traffic control, which is responsible for organizing the safe movement of our crowded airlines, 

depends on a significant amount of Computer support. As flying speeds increase, control has to be taken more quickly. Th is 

also applies to the pilot who has to react not only to instructions relayed to him from traffic control, but also to changing 

situations during flight (variations in atmospheric pressure, wind speed and direction).  

 
Flight Simulation : Besides many in-flight uses, Computer plays an increasingly vital role in the train ing of pilots. A flight 

simulator prov ides an e xact replica of the f ligh t  deck and performance of an aircraft, enabling the equivalent of many 

hours of flying  to be undertaken without leaving the ground.  

 
1.3 COMPONENTS OVERVIEW   
 
Computer system is made up of a number of components. These are Input device, output devices, different types of memory 

and central processing unit. Figure 2 shows different components of computer system. 
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1. 
                                                                                    Figure 2 
 
1.3.1CENTRAL PROCESSING UNIT (CPU)  
 
The central processing unit (CPU) is where the actual processing takes place. This is where the calculations are performed and 

logical functions are carried out. The CPU retrieves its data and instructions from the main memory, process the data 

according to the instructions, and then stores the results back into the main memory or sends the processed information to the 

output sub-system. There are broadly three parts of Central Processing Unit. Control un it controls all the operations in 

computer. All the arithmet ic and logic operations are performed in Arithmet ic and logic unit (ALU). A set of registers is used 

or temporarily storing data or instructions in CPU. 2. 

1.3.2 KEYBOARD, MOUSE AND VDU  

Keyboard 
To solve a problem it is necessary to give data and Instructions to the Computer. This can be done through input device. The 

keyboard is an example of an input device that accepts data and translates it into electronic signals. Both program 

(instructions) and data can be keyed in through it. In addition, certain commands to software can be given from the keyboard.  

The keyboard consists of a set of keys. There is one key switch for each letter, number, symbol etc., much like a type writer. 

Most common keyboard is called qwerty keyboard as the alphabets in the first row are placed like commonly used typewriters. 

When a key is pressed, the key switch is activated. The keyboard has an electron ic circuit to determine which key has been 

pressed. A code is then generated and sent to the computer. For example when you press the alphabet A on the keyboard, it is 

translated into the electronic code 0100001, which is sent to the Computer.. Detecting which key is pressed and generating 

the corresponding code is known as encoding. ASCII (American Symbolic Code for Information Interchange) is one such 

commonly used codes.  

Mouse  

Mouse is a pointing device which can be moved on a smooth surface to simulate the movement of cursor that is desi red on the 

display screen. Mouse could be optical; offering quite and reliable operation, or mechanical which is cheaper. User can move 

the mouse, stop it at a point where the pointer is to be located and, with the help of buttons, make selection of choices.  

 

VDU  

One needs to be able to see what one has keyed in, and make changes in case of any mistakes. Whatever one has keyed in, gets 

displayed on the screen of the monitor also known as video display unit (VDU). It is also used to show the information 

produced by the computer. Most display screens of a monitor work under the same princip le as a television, using a cathode 

ray tube (CRT). Consequently, the term CRT is often used in place of d isplay screen. 

VGA (video graphics array) or SVGA (Super VGA) monitors are most frequently used Monitors today. Both these terms 

generally refer to the resolution capabilit ies of the monitor. Most modern monitors can display 1024 by 768 pixels, the SVGA 

standard. Some high-end models can display 1280 by 1024, or even 1600 by 1200.  

 

1.3.3 OTHER INPUT DEVICES  

Data can be fed Into a Computer through Input devices. Input devices accept data in Its original format and translate the data 

into electronic signals that the Computer can process.  
Pointing Devices  

While working with display based packages, we are mostly pointing to some area in the display to select an option and move 

across on the screen to select subsequent options. For such cases pointing devices are very useful. There are several pointing 

devices; some of them are light pen, track balls and joysticks.  

Light Pen  

This is  a pen shaped device allowing natural movement on the screen. The pen contains the light receptor and is activated by 

pressing the pen against the d isplay screen. Receptor is the scanning beam, which helps in locating the pen's position. Suitable 

system software is provided to in itiate necessary action when we locate an area on the display surface with the help of the light 

pen.  

Voice/Speech Input  

One of the most excit ing areas of research is in recognizing human voices/ speech so that this could form input to computer 

directly. Th is approach will eliminate the need for keying in data and will facilitate casual users to use the computer very 

easily. Voice recognition techniques along with several other techniques to convert the voice signals to appropriate words and 

derive the correct meaning o f wo rds are required for a commercially viable comprehensive speech recognition System. Today 

devices are available commercially to recognize and interpret human voices within limited scope of operation.  

Scanners  

Scanners facilitate capturing of the informat ion (an image, text document, a d rawing or a photograph) and storing them in 

graphic format for displaying back on the graphical screen. Scanner illuminates the page that is to be scanned so that optical 

image transforms into digital format for storage by computer. The graphic image scanned can now be seen and processed 

directly by the computer. Scanners come in hand-held, feed-In and flat bed types and for scanning black-and-white only or 

color.  

1.3.4 OTHER OUTPUT DEVICES  
An output device is a part of the computer system which is used to show results. Output devices convert information from the 

electronic form used by the Computer into a form that people can easily work with. Output normally can be produced in two 

ways; either on a display unit or on a paper. Other kinds of output such as speech output, mechanical output are also being 

used in certain applications. Printer receives data from the Computer and translates the data into a printed document.  

Display Dev ices  

One of the most important peripherals in computer is the display device. Graphic display is made up of a series of dots called 

'pixels' (picture elements) whose pattern produces the image. Each dot on the screen is defined as a separate unit, which can be 

directly addressed. Since each dot can be controlled indiv idually there is much greater  



4 

 

flexib ility in drawing p ictures. There are three categories of display Screen technology:-  

1. Cathode Ray Tube (CRT) 

2. Liquid Crystal Display (LCD) 

3. Projection Displays  

CRT Dis plays  

The CRT (cathode Ray tube) monitor receives video signals from the computer and displays the video informat ion as dots on 

the CRT semen. The main unit in the CRT monitor is the CRT itself; it is usually called a p icture tube. The CRT is an 

evacuated glass tube with a fluorescent coating on the inner front surface, called screen. An electron gun at one end (neck) 

emits an electron beam. This beam is directed towards the screen. When the beam strikes the screen, the phosphor coating on 

the screen produces illumination at the spot where the electron beam strikes.  

 

The electron beam is deflected by an electromagnet ic deflect ion In order to produce illumination at various spots on the 

screen. Horizontal deflect ion co ils deflect the beam in the horizontal direct ion and the vertical deflect ion co ils deflect the 

beam in the vert ical d irect ion. The illuminat ion caused on the screen exists for a few milliseconds due to the persistence 

of the phosphor. To create a permanent image on the screen, it is necessary to cause illuminations repeated ly. Th is is 

done by scanning the CRT screen with the electron beam. There are two types o f CRT d isplays : 

1. Vector CRT d isp lays in which the electron beam is d irected on ly to the p laces where the image is to be created.  

2. Raster Scan d isp lays in  which the image is pro jected on to the screen by direct ing the electron beam across each row 

of p icture elements from the top to the bottom of the screen. Th is type o f d isplay prov ides a high dynamic capability  

since image is continuous ly refreshed and it allows for continual user input and output. It offers full co lor display at a 

relat ively low cost and is becoming very  popular.  

Liquid Crystal  Dis plays (LCD)  

First introduced in watches and docks in 1970s, LCD is now applied to d isplay dev ices of a co mputer. The major 

advantage of LCD is the low energy consumpt ion. The CRT is rep laced by liqu id crystal to produce the Image. These 

also have co lor capability but the image quality is relat ively poor. First Introduced in watches and clocks In 1970s, LCD 

is now applied to d isplay dev ices of a computer. The major advantage o f LCD is the low energy consumpt ion. The CRT 

is replaced by Liqu id crystal to produce the Image. These also have color capability but the Image quality is relat ively  

poor.  

Projection Dis plays  

A large screen upon which images are pro jected rep laces the personal size screen of the prev ious d isplays. These are 

normally used for large group presentation. These systems can be connected to computer and whatever appears on the 

computer terminal gets en larged and pro jected on a large screen. Another popular method is to connect computer to an 

LCD flat screen and to pro ject the LCD image us ing Overhead Pro jector. These are popularly  used for seminars, 

classrooms , market ing presentat ions, etc.  

Term1nals  
Terminal is a combinat ion o f input unit and output  unit  like VDU and keyboard. Terminals have become very  popular 

interact ive input and output units. With the help of a terminal data and instruct ions can direct ly be sent into the 

computer. Terminals can be classified into two types, namely hard copy terminals and soft copy terminals. A hard copy 

terminal prov ides a printout on paper where a soft copy terminal prov ides a visual display on screen. A soft copy terminal 

is also known as a CRT (Cathode Ray Tube) terminal. Terminals are also classified as dumb terminals or intelligent 

terminals depending upon prov is ion for any intelligence or otherwise as the terminal. Current technology has brought  

about a low price d ifference between intelligent and dumb terminals. Th is encourages use o f intelligent  terminals.  

 

Printers   

Printer is a very common and popular output device. It accepts text and graphic output f rom a computer and transfers the 

in format ion to  paper, usually to standard s ize sheet o f paper. Printed output provides a permanent record and is easy to 

copy and distribute. Familiar, computer printed documents include pay     slips, bank statements, electric ity b ills, etc. 

Different types of printers with different brand names are available in the market. They vary in size, speed, sophist icat ion, 

and cost. Generally we d iv ide the printers into  two categories: impact  and non-impact.  

 
Impact Printers  

Impact printers are printers that create characters by striking a print page with a print hammer (like in typewriter). The 

impact  printers developed for use with computers work in  much the same way as typewriter.  

1. Dot Matr ix Printer  

This is also a character printer. In the dot-matrix printer, an arrangement o f t iny hammers strikes to produce the desired 

characters. Each hammer prints a s mall dot on the paper.  

2. Line Printer  

It prints a line at a t ime. In the line printer, raised characters extend the length of the drum. There are as many bands of 

type as there are print ing posit ions. Each band contains all the possible characters. The drum rotates rapidly , and one 

revo lut ion is requ ired to print each line. A fast act ing hammer opposite to each band strikes the paper against the proper 

character as it  passes. Thus, in one rotat ion, hammers of several positions may ñfireò when the A row appears several 

others may strike to imprint D's, etc. At the end o f the rotat ion, the line has been printed.  

Non-impact Printers  

As their name implies, non-impact printer employ some process other than hammers or Similar "percussion type" 

mechanis ms to form characters on a print page. It uses techniques such as in spray, heat, Xerography or laser to form 

printed copy, i.e., characters are not formed by mechanical impact. Usually , non-impact printers are quieter than impact 

printer, Examples of non ï impact printers include inkjet  printers & laser printer.  
1. Inkjet Printer  

It is a non-impact  character printer. It  fires a fine jet o f dots o f qu ick dry ing Ink onto the paper to form character o r dot  

graph ics by using an electrostatic field . When continuous-stream inkjet printers are used, droplets of ink are electrically  

charged after leav ing a nozzle. The drop lets are then gu ided to  the proper posit ion on the paper by electrically charged 

deflection p lates. The print quality  is good because the character is formed by dozens of t iny dots. 

 
2. Laser Pri nters  

They are page printers, i.e., print a whole page at a time. Laser printers write the desired output image on a copier drum with a 

light beam that operates under computer control. A difference in an electric charge is created on those parts of the drum 

surface exposed to the laser beam. These laser-exposed areas attract a toner that attaches itself to the laser- generated charges 

on the drum. The toner is then permanently fused on the paper with heat or pressure, Laser printers ere quiet, and they produce 
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high-quality output.  

1.3.5 CO MPUTE R ME MO RY  

There are different types of memories, which are used in computer. Primary memory has other names as Main memory or 

Random Access Memory (RAM). CPU uses it to store or retrieve data and instructions for processing. Secondary memory or 

Auxiliary  memory is used to store the data and instructions permanently. Hard d isk and floppy disk are the examples of 

secondary memory. Compact Disk Read Only  memory (CO ROM) is also used to store the data permanently but it requires 

CD writer to store data into it. Cache memory is used to enhance the performance of Computer system.  

MAIN MEMORY  

Data and instructions are required to be stored in main memory from where it  can be retrieved by central processing unit  for 

processing results. Main memory serves as a temporary storage area for data and instructions. It is made up of a large number 

of cells, with each cell capable of storing one bit. The cells may be organized as a set of addressable words, each word storing a 

sequence of bits. The time to store and retrieve a word is Independent of the address of the word. This organization is also 

cal led RAM or Random Access Memory. The main memory is very fast. Its storage capacity is in gigabytes. Nowadays most of 

the Computers have minimum of 1 G bytes of RAM. A ll the modem computers are now bu ilt with semiconductor main 

memory because of its fast access time, low cost, small physical size and low power consumption. RAM is further classified 

as either dynamic RAM (DRAM) or static RAM (SRAM).  

The larger capacity chips are normally constructed as dynamic RAM because the dynamic RAM requires less number of 

transistors than the static RAM and hence can be packed more densely on a single chip. Thus dynamic RAM can achieve 

higher storage density. DRAM is implemented using capacitors which tend to loose their charge with time and need periodic 

refreshing. So, it needs extra control circuit ry. This refreshing process slows down memory access speed slightly. SRAM, on 

the other hand, does not need any such refreshing circuitry. Thus, a SRAM is faster than a DRAM, DRAM is cheaper than 

SRAM and consumes less power than SRAM.  

SECONOARY MEMORY  

The programs & data that are required to be used again & again, are kept in auxil iary or secondary memory. The present day 

capacity of Hard disk is 500 Giga bytes. Because of its relatively slow speed, auxiliary storage is used for storing programs 

and data not immediately needed by the Computer. The programs and data are then copied into faster main memory when the 

Computer is ready to process them. Secondary storage devices are online to the processor. They accept data or program 

instructions from the processor, retain them, and then write them back to the processor as needed to complete processing 

tasks. Some of the secondary memories are: 

Floppy Disk  

The floppy disk gets its name from the fact that it is made out of a flexible plastic material. The plastic base is coated with an 

iron-oxide record ing substance that is similar to the materiel applied to the plastic ribbon of a magnetic tape. Data are recorded 

as tiny invisible magnetic spots on this coating. The disk is loaded and rotated inside its envelope. Tiny electromagnetic heads 

in the disk reader access the data through the slot in the jacket. A floppy disk is divided into tracks (these are a series of 

concentric rings on the surface of the disk) and each track is further d ivided into sectors. The number of t racks that a disk can 

hold is measured in tracks per Inch (tpi) and it is always mentioned on any floppy disk you buy. A diskette is inexpensive and 

can be erased and reused many times.  

Hard Disk   

The disk described so far is the type of disks which can be removed from the disk drive and carried from place to place. Some 

disks however, are built into the computer or a special disk drive. These are fixed disks. They are used in just the same way as 

removable disks, but tend to be used for storing programs or data which have to be permanently available. Hard disks can 

store anywhere from 20 MB to more than 500GB. Hard d isks are also from 10 to 100 times faster than floppy disk.  

CD-ROM  

The CD-ROM (Compact disk Read-Only Memory) is a direct extension of audio CD. CD-ROM players are more rugged and 

have error-correction facility. This ensures proper data transfer from CD-ROM to the RAM of the compute. CD - ROM is 

written using a CD writer. In formation is retrieved from a CD-ROM using a low power laser, which ingenerate in an optical 

disk drive unit. In CD-ROMs the information is stored evenly across the disk in segments of the same size. Therefore, in CD-

RO Ms data stored on a track increases as we go towards outer surface of disk. Thus, the CD-ROMs are rotated at variable 

speeds for the reading process.  
 

CACHE MEMORY  

CPU speed is quite high as compared to the access time of main memory. In  many situations, the performance of the processor 

suffers because of the low speed of the main memory. It is problem is solved by placing small fast memory called cache 

memory between the processor and the main memory whose access time is close to the processing speed of the CPU. Cache 

memory is faster than the main memory. The cache memories although are fast yet are very expensive memories and are used 

in only mall size. Thus, small cache memories are intended to provide fast speed of memory retrieval without sacrific ing the 

size of memory.  

Cache memory stores a copy of the instructions and data to be immediately used, of main memory. The memory read or write 

operation is first checked with cache memory and if the desired locat ion data is available in cache memory then used by the 

CPU d irectly. Otherwise a b lock of words is read from memory to cache memory and CPU uses the word from cache memory.  

1.4 CONCEPT OF HARDWARE AND SOFTWARE  

In this section we shall distinguish between hardware and software used in a Computer. There are d ifferent types of software 

and there are several generations of the programming languages.  

1.4.1 Hardware  
The electronic circu its and mechanical components of a computer such as hard disk, printers, central processing unit keyboard, 

mouse, motherboard and other peripheral devices, which are tangible in nature, or which can be felt, touched are known as 

hardware.  

1.4.2 Software  

Programs namely the list of instructions to be executed by computer is known as the software of the computer. There are 

different types of software depending on the requirement of user or Computer. Software falls into two general categories:  

a) System Software  

b) Application Software  

System software  

System software controls and coordinates Computer operations, and unifies all of the Computer components into a functional 

and smooth running system. System software also prov ides the Computer users with a means of gaining access to the system 

and its resources. The task of translating instructions into machine code is done by a special set of software called the 

Compiler. Operating system prepares the computer for use and also controls the different devices attached to the computer. 
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Operating system & Compilers are the example o f system software.  

Application software  

Application software refers to the programs, which allow the Computer to carry out specific tasks related to the users such as 

payroll processing, inventory control, or word processing. Application software may be supplied by the Computer 

manufacturer or software vendors, or may be written by programmers.  

 

1.5 REPRESENTATION OF DATA /INFORMATION  
 
Computers can be programmed to perform many different tasks. However, before the Computer can perform any task, it must 

be given the data to be processed, and the proper instructions telling it how to process the data.  

1.5.1 Definition of Data And Information  
The data is processed to give us useful information as an output. For example: 19,4,9,2002, Delhi are nothing but raw data 

as they do not convey any meaningful in formation. However, If we say that the city of Delhi received 4 mm of rainfall on the 

19th day of the 9th month of 2002, it is In formation.  

1.5.2 Representing Data In The Computer  

Basic component of Computer like CPU, RAM etc are transistors. These are made of a number of Integrated circuits (ICs), 

which contain transistors. These transistors act like a two-way switch which can be either on or off. These transistors have just 

two operating states: either on or off. When a transistor is switched on, it is said to represent the value 1. Conversely, when 

the transistor is switched off, it is said to represent the value 0. The values 0 and 1 are the only two dig its with which computer 

works.  

Thus all data to be stored and processed in Computers are transformed or represented as sequence of two symbols, one 

symbol to represent each state. The digits 0 and 1 are represented inside the Computer as electrical voltages. The electrical 

voltages have just two states, or levels, referred to as high and low. Usually the low voltage represents a value of 0, while the 

high voltage represents a value o f 1.  

1.5.3 Bits and Bytes  

The term Bit is an acronym for Binary d igit. The bit is the smallest piece of in formation that the Computer can work with. The 

values 0 and 1 are called Bits. Bits are grouped together to form a larger chunk of information called a Byte. A byte consists of 

eight bits that the Computer stores and processes as single entry. A byte represents one character of data (either a letter of the 

alphabet, decimal d igit, or symbol). The Computer can store individual bytes in its memory and later retrieve them. 

 

 
8 Bits 1 Byte 

1024 Bytes 1 Kilobyte 

1024 Kilobyte 1 Megabyte 

1024 Megabyte 1 Gigabyte 

 

Representing data in Computer 

 
 

1.6 APPLICATIONS OF IECT  

1.6.1 E- Governace 

The model for e-governance is a one-stop portal, such as firstgov.gov, where citizens have access to a variety of information 

and services. An ideal portal would be one for employment where a cit izen creates a profile and is presented with employment 

opportunities at the federal, state, local, non-profit and private-sectors 

The primary delivery models of e-Government can be divided into: 

¶ Government-to-Citizen or Government-to-Customer (G2C)  

¶ Government-to-Business (G2B) 

¶ Government-to-Government (G2G) 

¶ Government-to-Employees (G2E)  

 

Within each of these interaction domains, four kinds of activities take place: 

¶ Pushing information over the Internet  e.g: regulatory services, general holidays, public hearing schedules, issue 

briefs, notifications etc. 

¶ Two-way communications between the agency and the citizen, a business, or another government agency. In this 

model, users can engage in dialogue with agencies and post problems, comments or requests to the agency. 

¶ Conducting transactions e.g: lodging tax returns, applying for services and grants. 

¶ Governance  e.g : online polling, voting and campaigning. 

 

1.6.2 Multimedia and Entertainment 

Multimedia is a combination of sound and images with text and graphics. This would include movies, animations, music, 

people talking, sound effects like the roar o f a crowd and smashing glass. 

Sound Input 

Recording sounds for your computer requires special equipment. Microphones can capture sounds from the air, wh ich is good 

for sound effects or voices. 

Vo ice Input 

Talking data into the computer when your hands and eyes are busy should certainly be more efficient. You can tell the 

computer what to do instead of typing commands, like saying "Save file". One has to be careful enough while g iving the sound 

input with regard to pronounciation of words. Also there could be a problem that dictionary of understood words does not 

include some of the more "forcefu l" words. 

Video Input  

A Dig ital Camera takes still photos but records the pictures on computer disks or memory chips. The informat ion contained 

can be uploaded to a computer for viewing. 

A Video Camera or Recorder (VCR) can record data that can be uploaded to the computer with the right hardware. Though it 

is not digital data, you can still get good results with the right software. Both of these take huge amounts of storage. Photos 

make for very large files.  
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A Web Cam is a tiny video camera designed especially to sit on your computer. It feeds pictures directly to the computer as 

their would be no tape or film to develop. Of course the length of the cable that connects the camera to the computer would be 

a limiting factor. But like any camera, it will take a picture of what you point it at. 

Check Your Progress  

1. List three parts of the Computer.  

2. What do you understand by the term RAM. 

3. 1 MBYTES =  bytes 

4. Give two examples of System Software.  

 

1.8 SUMMARY  

Applications and uses of Computer  

Various parts or Computer  

Different types of memory  

Different types of Computers  

Difference between various computer languages  

Difference between application and system software  

Data representation in a Computer e.g. bits & bytes  

1.9 MODEL ANSWERS  

Ans. l  

(a) CPU  

(b) Memory  

(c) Input & Output devices  

Ans.2 Random Access Memory  

Ans.3 1024 Kilobytes  

Ans.4 Operating. System and Compiler  
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Chapter 2: OPERATING COMPUTERS USING GUI BASED OPERATING SYSTEM  
 

2.0 INTRODUCTION  

We will now discuss various user-friendly features of windows operating system. Microsoft has produced a number of 

Operating Systems. Windows 95/98/ME, Windows NT, Windows 2000 Professional/Advance server are some' of them. The 

Operating system which we have selected as reference is Windows 2000 Professional and we will focus our studies on it.  

An operating system plays an important role in the use of Computer. It prepares a bare machine for use by the user. In other 

words an operating system works as an interface between Computer and user. The operating system enables the user to 

effectively  use the system resources and access several other programs. Windows operating system offers a new graphic based 

interface to the users and they can use mouse to perform a number of operations. It is also possible to work on multiple 

windows at a time.  

An operat ing system is a set of system programs which provides a number of facilities to the user for easy use of the  

Computer. An operating system: 

 

¶ Controls and coordinates the operation of a Computer  

Easy interaction between user and Computer  

¶ Starts the Computer automat ically when power is turned on  

Controls input and output  

¶ Controls program execution  

Manages use of main memory  

¶ Manages and manipulates flies  

 
 

2.1 OBJECTIVES  

After going through this chapter, you will be able to :  

¶ Define operating System  

¶ List various features of Windows operating system 

¶ Familiarize yourself with the Windows 2000 Interface,  

¶ Use Windows operating system in managing files and folders 

¶ Explain how multip le Windows work,  

¶ Work on W indows accessories like Notepad, Paint  

 

2.2 BASICS OF POPULAR OPERATING SYSTEM  

Windows and Linux both have a user friendly Graphical User Interface (GUI). GUI includes such things as: windows, pull-

down menus, buttons, scroll bars, iconic images, and wizards. They allow users to interact with the programs without having 

to type the commands from the keyboard. Users can use pointing devices like mouse to perform specific tasks on computer. 

 

2.2.1 LINUX  

Linux is a mult itasking, multiuser operating system, which means that many people can run many different applications on 

one computer at the same time. Linux is a generic term referring to Unix-like computer operating systems based on the Linux 

kernel. Their development is one of the most prominent examples of free and open source software collaboration, typically all 

the underlying source code can be used, freely modified, and redistributed both commercially and non-commercially. Linux is 

predominantly known for its use in servers, although it can be installed on a wide variety of computer hardware. Linux 

distributions, installed on both desktop and laptop computers, have become increasingly commonplace in recent years. The 

name "Linux" comes from the Linux kernel, originally written in 1991 by Linus Torvalds.   

 
2.2.2 Microsoft Windows  

 

Windows operating system is GUI based and can be used on desktop computers. Its interface has following properties :- 

Title Bar : - The title bar contains the name of the program you are working with and in some cases the name of the opened 

document also appears. In the top right corner we can find the Min imize, Maximize/Restore, and Close buttons.  

Menu Bar :- The menu bar has the program functions organized in menus. For example, when we click on File, the different 

operations that can be performed with files are displayed. All the operations that the program allows us to do are located 

within the different menus. 

Tool Bar :- The tool bar contains icons to immediately execute some of the most often used commands. 
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Scroll Bars :- The scroll bars allow us to move through out the page in a quick and simple manner. Simply drag the bar with 

the mouse or click on the arrows. There are bars to move along the width of the page and bars to move along the height of the 

page. The little square with dots on the right is used to change the size of the window. Simply click and drag. 

Status Bar :- The status bar is used to give user certain information pertaining to the current program. The information 

displayed on it varies depending on the program window which is opened at that time. 

Desktop :- The Desktop is the on-screen work area on which windows appear. it is the first screen that appears when the 

operating system has init ialized. In our case it will be the Windows XP desktop. 

 
2.3 USER INTERFACE  

2.3.1 Task Bar 

The taskbar is the long horizontal bar at the bottom of your screen. Unlike the desktop, which can get obscured by the 

windows on top of it, the taskbar is visible almost all the time. It has four main sections :- 

Start button, : - It is used to open the Start menu.  

Quick Launch Toolbar :- It lets you start programs with one click. 

The middle section :- It shows you which programs and documents you have opened and allows you to quickly  switch 

between them. 

The notification area :-  It includes a clock and icons (small pictures) that communicate the status of certain programs and 

computer settings. 

 

 

 

  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2.3.2 USING DIFFERENT MOUSE OPERATIONS   

Click  

Hol d down the left mouse button and press to activate certain programs through icon.  

Double click  

Click the left mouse button in quick succession to run any program or application.  

Drag & drop  

Select the required text area or picture or object, press the left mouse button and drag it to another area by holding the left 

mouse button. It moves the selected contents from the original place and drops them at the place where mouse button was 

released.  

2.3.3 ICONS  

A co mputer icon is a graph ical s y mbol that repres ents a property , funct ion, or ent ity . In co mputer 

app licat ions , icons  are us ed to qu ick ly  execute co mmands or open progra ms  and docu ments . You access the 

funct ionality beh ind an icon by click ing or double-clic king it . Operat ing s yste ms often allo w you to  

custo mize v is uals  o f various  ob jects  by  app ly ing your o wn custo m icons . 
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2.3.4 Start Menu 

Start Menu is located at the leftmost corner of the status bar. Using mouse, left click on the start menu which displays various 

options available. The start menu shows various options on it like Programs, Internet Explorer, Shut Down etc. These can be 

activated using a double click on these icons.  

For Menu Selection, you have to move to the desired option first and then  Double click it to open the respective program.To 

shut down the system you can click on the Shut Down/turn off computer option that appears at the bottom of the Start Menu. 

Another option available along with Shut Down is Logoff. 

 

2.3.5 Running an Application 

 

To run any program/applicat ion, fo llow the given steps :- 

1. Click Start, and then click Run.  

2. In the dialogbox that appears, type the path to the item you want to open in the space provided after Open:, or click Browse 

to locate it.  

The Open box lists items you have opened recently. Type or select an item in the list. 

3. Click OK to open it.  

You can open a file or folder or connect to a shared computer by typing its path in the Open box.  

You can also connect to an Internet or intranet site; for example, to reach the Microsoft Web site, type www.microsoft.com in 

the Open box.  

You can connect to a remote computer using the open box. 

 

2.4 OPERATING SYSTEM SETTINGS AND UTILITIES  

Contro l Panel is fu ll of specialized too ls that are used to change the way Windows look and behave. Some of these tools 

help you ad just settings that make your computer more fun to use. To open Control Panel, click Start and then click 

Contro l Panel.  

When you first open Contro l Panel, you will see some of the most commonly used contro l panel items organized by 

category . To find out more in format ion about an item in contro l panel while in Category v iew, ho ld your mouse po inter 

over the icon or category name and read the text that appears. To open one o f these items , click its icon or category  

name. Some of these items will open to a list of tasks you can perform, as well as a select ion of ind iv idual contro l panel 

items . 

 

2.4.1 CHANGING SYSTEM DATE AND TIME  

 

Double click Date/Time icon in Control Panel. Following screen appears. This icon changes date, time and time zone 

informat ion. In the date and time tab the date, month and year along with the time and the time zone can be changed in the 

time zone tab.  
 

2.4.2 CHANGING DISPLAY PROPERTIES   

 

Win2K Pro offers variety of options that enable you to change the way the graphical user interface or desktop behaves. Double 

click Display icon in Control Panel. Following screen appears. 

  

To Change the backgr ound screen  

You can change the background screen of the window with the help of options available in the background tab of display  

properties. Select the wallpaper and the display option from it and dick on OK.  

 

 
 
 
 

 
 

 
 

 
 

 
 

 
 

 
 
 

 
 

To change the screen s aver  

With the help of screen saver tab one can set the desired screen saver, set the timing; assign a password for the screen saver to 

protect your files. To change the settings of the screen saver you can use the settings options.  

 

To change windows  appearance style  

One can change all the windows default settings with help of appearances tab. Choosing a proper scheme places a 

representation of that scheme in appearances box. One can also define his own scheme and add it to the existing list.  
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To change the desk top effects :  

Effect tab is meant to set the icons for system objects on your desktop. Effects also include some animat ion and window  

display attributes. Following steps can be used to vary the icons for system objects on the desktop.  

1. In the effects tab select the particular desktop icon you want to change. 

2. Click the change icon button. The change icon dialog box appears. The file name text  box displays the particular file  

containing the icons. Select an icon and then choose OK.  

3. If you want to use an icon from elsewhere, d ick on the Browse button and search for other files containing that icons. 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.4.3 TO AD D OR REMOVE A WINDOWS COMPONENT  

You can open the Add/Remove Programs properties dialog box at the Windows Setup tab by clicking Start, pointing to  

Settings, click Control Panel, double-clicking Add/Remove Programs, and then clicking the Windows Setup tab. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

Under Components, click the component you want to add or remove.  

 

¶ To add all parts of the component, select its check box.  

¶ To remove all parts of the component, dick to clear its check box.  

To add or remove some parts of the component, click Details, and then click to select or dear check boxes for those parts.  

 
2.4.4 CHANGING MOUSE PROPERTIES  
 
Double Click Mouse icon in Control Panel. Fo llowing screen appears. This option changes settings for mouse.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Button tab:  

In the mouse icon window select the buttons tab.  
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In this tab you can swap the mouse buttons and adjust the double dick speed.  
 

Pointer tab:  

Pointers tab is used to change the default mouse pointers. Select the pointer shape you want to change and then click on 

browse button. It will  disp lay you a list of pointer shapes. Select a part icu lar shape and then click on open button to open  

the file. In the defau lt d ialog box d ick on app ly button fo llowed by OK.  

 

 
   

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Motion tab  

 

In the motion tab of the mouse propert ies dialog box one can change the po inter speed and add a po inter t rail to  the  

pointer. 

  

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2.4.5 ADDING AND REMOVING PRINTERS  

 

Double click Printers icon in Control Panel or click on Start, po int ing to Sett ings, click Printers. Fo llowing screen 

appears. It is used to  add, remove and change setting for printers. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To change printer s ettings  

Right-click the icon for the printer you are us ing, and then click Properties. The settings you can change depend on the 

type or printer you have. Click the d ifferent tabs to see all o f the opt ions you can set .  

To s et  up a printer  

1. Double-d ick on Add Printer.  

2. Follow the instruct ions g iven on the screen.  

 

Check Your Progress  

Q1.What is the use of a contro l panel?  
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Q2.What do you understand by the term recycle b in?  

Q3.How is screen saver is changed?  

 

2.5 OPERATIONS ON FILES  AND FOLDERS  

To view a file or folder  

1. Double dick the drive that contains the file.  

2. To view a file or folder, double click on it .  

Copying and movi ng of fi les  

You can open the folder that contains the file you want to move and drag it to the folder you want to put it  in. To copy a file  

hold down the control key and to move a file, hold down the shift key while dragging.  

OR  

1. Locate the file or files you want to move or copy. 

2. Select the files.  

3. Choose copy or cut from the edit menu, the too l bar or right click the context menu. 

4. Locate the place to which you want to move or copy the objects. Click on it. 

5. Choose paste from the toolbar, the edit  menu, or the right click context menu.  

To create a ne w f ol der  

1. In the windows exp lorer, i f you want to create a new folder then select New option from File menu.  

2. Select Fo lder option from the submenu.  

3. Type a name for the new folder and then press enter.  

To Delete a File or Fol der:  

1. In windows exp lorer; locate the fil e or folder you want to delete.  

2. Click the file or folder.  

3. On the file menu, click Delete.  

If you want to retrieve a file you have deleted, look in the Recycle Bin. The deleted files remain in the Recycle Bin until you 

empty it. You can also drag file or folder icons onto the Recycle Bin icon. If you press shift while dragging, the item will be 

deleted from the computer without being stored in the Recycle Bin.  

To Change The Name Of the File Or Folder:  

1. In windows explorer, click the f ile or folder you want to rename. You do not need to open it.  

2. On the File menu, click Rename.  

3. Type the new name, and then press ENTER.  

A filename can contain up to 255 characters, including spaces. But it cannot contain any of the following characters  

:* ? ;  

To select multiple  fil es and folders  follow given steps:  

1. In the folder window, hold down the CTRL key and then dick each item to be selected.  

2. To select all the files and folders in the window, click the Edit menu, and then dick Select A ll.  

3. To select a group of files that are next to each other, hold down the mouse button and drag a rectangle around the files you 

want to select.  

4. To change the appearance of items in a folder in windows exp lorer, dick the View menu, and then click one of the following 

commands: Large Icons, Small Icons, List, or Details.  

To Change the Appearance of i tems i n a folder  

In my computer or exp lorer click the view menu, and then click one of, the following commands: Large icons, Small icons, 

List, Details. You can also sort the items by name, size, date and type depending on the view.  

To print a docume nt:  

1. If the document is open, on the File menu, click Print.  

2. If the document is not open, drag the document from My Computer or Windows Explorer to your printer in the Printers 

folder.  

3. While a document is printing, a printer icon appears next to the clock on the taskbar. When this icon disappears, it means 

that your document has finished printing.  

4. For easy access to your printer, you can create a shortcut to it on the desktop.  

To Send Files To Another Place:  

1. Select the file in the exp lorer and then choose Send To option from File menu to exp lorer.  

2. Or click the right mouse button and select Send To option from the shortcut menu.  

3. You can select the destination type from the submenu under Send to option. 

 
To Share A Folder With Others:  

1. Click the fo lder you want to share.  

2. From the file menu select sharing option.  

3. Select the Sharing Tab from the Dialog Box, choose the shared as option and the corresponding details required.  

4. You can also share Disk Drives by using above mentioned procedure.  

 

To Change File or  Folder Properties  

In the Windows Explorer, click the f ile or folder whose properties you want to change and then select Properties option from  

the File menu.  

OR  

When you want to view or change informat ion about any item, such as a document, program, folder, disk drive or printer, you 

can look at its  properties. Use the right mouse button to dick the item, and then click properties on the menu.  

 

2.5.1.2 CREATING SHORTCUTS  

 

Instead of Using the standard menus to find the command you need, use the right mouse button to click a file or fo lder. The 

menu that appears shows the most frequently used commands for that file or folder. You can put a Shortcut to any program, 

document, or printer on the desktop or in any folder. Shortcuts are quick ways to get the items you use often. For example you 

can create shortcuts to the printer by using the right mouse button to drag its icon to the desktop. Then to print a file, just drag 

its icon to the printer icon.  

 

To Create a Short -cut i n a Folder  

 

In windows explorer, open the folder you want to create the shortcut in. On the File menu, point to New and then click 

Shortcut. Follow the Instructions on the screen.  
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2.5.2 WINDOWS ACCESSORIES  
 

2.5.2.1 NOTE PAD  

You can use Notepad to create or edit text files that  do not require formatting and are smaller than 64K. Notepad opens and 

saves text in ASCII (text-only) format only. To run Notepad, click on Start and point to Programs, take mouse pointer to 

Accessories and dick on Notepad. You can also type Notepad in the Run option of Start Menu. The following screen appears. 

User can type letters in the given area and click on save option In file menu to save the contents.  
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To open a document  

1. On the File menu, click Open. 

2. In Look In, click the drive that  contains the document you want  to open.  

3. Double-click the folder that contains the document you want to open. 

4. Click the document name, and then click Open.  

To delete text  

1. Select the text you want to  delete. 

2. To remove text so that you can place it in another part of the document, click Ed it, and then click Cut. 

3. Or to rem ove text  entirely from the document, press D EL ETE.   

To find s peci fi c characters or wor ds  following s te ps  are us ed:  

1. On the Edit menu, click Find.  

2. In the Find what box, type the characters or words you want to find.  

3. Click Find Next. 

 

 

 

 

To delete, cut, copy, and paste text  

1. To delete characters to the left of the Insertion point, press the BACKSPACE key.  

2. To delete characters to the right of the insertion point, press the DELETE key.  

3. To delete words, select them, and then press the BACKSPACE or DELETE key.  

4. To cut text so you can move it to another location select the text. Then, on the Edit menu, click Cut.  

5. To copy texts so you can paste a copy of it in another location, select the text. Then, on the Edit menu, dick Copy.  

6. To paste text you have cut or copied, place the insertion point where you want to paste the text. Then on the Edit menu, 

click Paste.  

To wrap, text to the window s ize  

1. On the Edit menu, d ick Word Wrap.  

2. Wrapping text enables you to see all the text on the line, but It doesn't affect the way text appears when it is printed.  

To Ins ert the time and date in a document  

1. Move the insertion point to where you want to  add the time and date.  

2. On the Edi t  menu, dick Time/Date.  

To keep a log by using Note pad  

1. On the first line of Notepad document, type the following at the left  marg in, making sure you include the period: .LOG.  

2. Save the document.  

Every time you open this document, Notepad will append the current time and date, as specified by your computer's clock, 

to the end of it.  

2.5.1 PAINT  

You can use Paint to create, edit, and view pictures. You can paste a Paint picture into another document you have created, 

or use it as your desktop background. You can even use Paint to view and edit scanned photos.  

To run Paint, click on Start and point to Programs, take mouse pointer to Accessories and click on Paint. You can also type 

Paint in the Run option of Start Menu. The following screen appears. User can type the letters or create images or graphics 

in the given area and click on save option in File menu to save the contents.  
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To dr aw a s traight line  

1. Click the requ ired button in the toolbox. 

2. To draw the line, drag the mouse pointer.  

To dr aw a free-for m l ine  

1. Click the required button in the toolbox.  

2. To draw the line, drag the mouse pointer.  

To draw a cur ve  

 
1. Click the curve tool in the toolbox.  

2. To choose the width the curve will be, click a line width at the bottom of the toolbox.  

3. To choose the color the curve will be, click a co lor.  

4. Draw a straight line by dragging the mouse pointer.  

5. Click where you want one arc of the curve to be, and then drag the mouse pointer to adjust the curve.  

6. Each curve must have at least one arc but no more than two. Repeat this step for a second arc.  

 

To dr aw an ecli ps e or Circle  

1. Click on the Circle tool in the toolbox 

2. To draw eclipse or circle, drag the mouse pointer. 

To create an ai rbrus h effect  

1. Click in the toolbox.  

2. To change the size of the spray area, click a size from the bottom of the toolbox.  

3. To choose the spray color, click a color.  

4. To spray drag the mouse pointer. Use the left mouse button to spray with the foreground color, or use the right mouse 

button to spray with the background color.  

To create cus tom c olors   

1. In the color box, click the color you want to change.  

2. On the Options menu, click Ed it Colors.  

3. Click Define Custom Colors, and then enter new values in either the RGB (red, green, blue) or HLS (hue, saturation, and 

luminescence) and color models.  

4. Click Add to Custom Colors.  

To us e black  and whi te ins tead of color  

1. On the image menu, click Attributes.  

2. Click Black and White.  

To invert all the colors  in a pi cture  

On the Image menu, click Invert Colors.  

To Change the color of an exis ting line  

1. Click in the toolbox.  

2. Clic k a d ifferent color in the color box.  

3. Position the paint cursor so that it is touch ing the line, and then click.  

To copy part of a picture  

1. Select the area you want to copy by click or in the toolbox and then dragging the cursor to define the area.  

2. On the Edit menu, click Copy.  

3. On the Edit menu, click Paste.  

4. Drag the selection where you want it. 

5. To remove the selection box, click outside it.  

To s ave part of a picture into another bi tmap file  

 

1. Select an area you want to save by clicking  or in  the toolbox and then dragging the cursor 

to define the area.  

2. On the Edit menu, click Copy To.  

3. Specify a file name and location.  

 

2.5.2.3 Character Map  

You can use Character Map to insert special Characters Into a document. To run Character map, click on Start and point to 

Programs, take mouse pointer to Accessories and click on Character Map. The following Screen appears.  

To add a s pecial  character to a docume nt  

1. Open Character Map.  

2. In Font, click a font.  

3. Double-click each character you want to insert.  

4. Click Copy.  
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5. In your document, click where you want the characters to appear.  

6. On the Edit menu, click Paste.  

7. Select the inserted characters, and then dick the arrow on the font list to change to the same font you used in Character 

Map.  

 

2.5.2.4 Calculator  

To run Calculator, click on Start and point to Programs, take mouse po inter to Accessories and click on Calculator. You 

can also type Calc in the Run option of Start Menu. The fo llowing screen appears.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To perfor m a si mple calculation  

1. Enter the first number in the calculation.  

2. Click + to add, - to subtract, * to mult iply, or / to div ide.  

3. Enter the next number in the calculat ion.  

4. Enter any remain ing operators and numbers.  

5. Click =  

To perfor m a s tatis tical  calculation  

1. On the View menu, click Scientific. 

2. Enter your first piece of data. 

3. Click Sta, and then click Dat.  

4. Enter the rest of the data, clicking Dat after each entry. 

5. Click Sta.  

Click the button for the statistics functions you want to use.  

To perfor m a scienti fic calculation  

1. On the view menu, click Scientific.  

2. Click a number system.  

3. Enter the first number. 

4. Click an operator. 

5. Enter the next number in the calculat ion.  

6. Enter any remain ing operators and numbers.  

7. Click =.  

To convert a value to another number Sys tem  

1. On the View menu, click Scientific.  

2. Enter the number you want to convert.  

3. Click the number system you want to convert to.  

 

2.5.2.5 SYSTEM TOOLS  

These system tools can be used to enhance the performance of the Computer. Backup is used to take back up of files present 

in hard disk. You can back up files to floppy disks, a tape drive or another computer on the network. Introduction to some of 

system tools is given below.  

Us ing Disk  Defrag menter to s pee d up the har d disk   

You can use Disk Defragmenter to rearrange files and unused space on the hard disk so that programs run faster.  

Using Drive Space to increase Disk Space  

You can use Drive Space to compress both hard and floppy dis ks to create more free space for f iles. You can also use Drive 

Space to configure disk drives that you have already compressed by using Double Space or Drive Space.  

Using Scandisk  to detect and repair  disk  errors :  

You can use Scandisk to check the hard disk for logical and physical errors, and then repair the damaged areas.  
2.5.2.6 CO MM UNI CATIO NS  

Utilit ies which are helpfu l in making communicat ion are grouped here.  
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Phone dialer to dial  from the compu ter:  

1. Select Programs from Start menu.  

2. Go to Accessories and the select  co mmunicat ion option.  

3. From the submenu select Phone Dialer.  

4. Phone dialer enables you to place telephone calls from the computer by using the modem or another Windows telephony 

device.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Us ing DIAL -UP Networking to c onnect to a Compu ter or Network   

1. Select  Programs from Start menu.  

2. Go to Accessories and the select communication option.  

3. From the submenu select Dial-Up Networking. 

 

With Dial-Up Networking, you can gain across to shared informat ion on another computer, even if the co mputer is not on 

a network. The computer you are d ialing in  to must be set up as a network server for you to use it's shared resources. for 

example, if you have a computer at home, you can dial in and connect to the work computer and network through a network 

server. Both the home computer and the network server must have modems installed. To start the dial-up networking setup 

wizard, double click My Computer, and then double-click Dial-Up Networking and follow the instructions.  

 

Check  your pr ogress   

Q4. How to create a fo lder?  

Q5. What is the use 'of character map?  

Q6. What is the use of Disk Defragmenter? 

 

2.6 SUMM ARY  

In this chapter we discussed various components of Windows 2000 professional like Desktop, start button, Start menu, My 

Documents, My computer, Recycle Bin and their functionalities. Some of the tools available in control panel were used to 

show how display settings, date and time could be changed. 

2.7 MO DEL ANSWE RS  

Ans.1 Control panel holds a group of tools that help to change the Software and Hardware settings.  

Ans.2 Recycle b in is an area which usually holds deleted files until it reaches a user configurable percentage of a disk's 

capacity. At that point i t discards them. It can be open up to restore something which had been thrown away earlier.  

Ans.3 Right click on the blank area in desktop and choose properties. With the help of screen saver tab one can set the 

desired screen saver, Set the timing, assign a password for the screen saver to protect your files. To Change the settings on 

the screen saver you can use the settings options.  

 Ans4  i)  In the window exp lorer, select New option from File menu.  

ii) Select Folder option from the-submenu.  

ii i) Type a name for the new folder end then press enter.  

Ans.5 Character map is used to insert special characters into a document.  

Ans.6  Disk Defragmenter is used to rearrange files and unused space on the 
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Chapter 3: Elements of Word Processing 
 

3.0 INTRODUCT ION  

MS Word is a software package offering features for sharing data and documents, communicat ion tools, Internet access and 

publishing capabilities. You can create letters, memos, reports, term papers with the help of MS Word. It can also help you to 

send documents to a group of people for feedback.  

3.1 OBJECTIVES  

After going through this chapter you should be able to:  

¶ Understand different bars and icons in MS Word  

¶ Open, print and dose documents  

¶ Scroll the documents, Change Font size, alignment, Format the document  

¶ Create and manage Tables  

3.2 WORD PROCESSING BASICS  

MS Word is software tool used for creating documents. It offers a number of features that are related to text processing. The 

interface of the MS word is similar to other windows products. It has several toolbars that can be viewed based on the 

requirements of the user. It also offers formatting of text that includes changing font size and style, paragraph spacing, line 

spacing, Indents, and alignments o f text etc. We shall be discussing the features that are required by a common person to create 

documents.  

3.2.1 Opening Word Processing Package  

1. Click on Start button at the bottom left corner of the Win2K Professional or any other Windows Operating system, as 

shown in the figure below.  

2. Select the Programs option of the Start menu.  

3. Select the Microsoft Word option from the Programs submenu. This invokes Microsoft Word and starts a new document.  

A new document window is displayed each time you start word. The document window contains individual Word files. This 

window differs from an application window, which is displayed even if no documents are open as long as Word is running. 

Word document window is shown below.  

 

 
 

 

 

 

 

 

 

 

 

 

 

The document window contains a number o f parts that are described below.  

Tit le Bar   
 
 

 
Displays the name of the program, the name of currently active Word document, the Control menu icon, Maximize button, 

Minimize button and Restore and close buttons. Double-clicking on title bar can alter the size of the Word window.  

Ruler Bar  

 

 

It enables to format the vertical alignment of text in a document and is also used to set tab stops on a line of text. You can 

select the Ruler option from the View menu to display or hide the ru ler bar.  

Status Bar  
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It displays the information about the active document on which you are currently working. This includes the page number 

and the column and line number on which you have positioned your cursor. Apart from these, there are five labels - REC, 

MRK, EXT, OVR and WPH.  

REC indicates macro recorder  

MR K indicates revision marking  

EX T indicates extend selection  

OVR Indicates overstrike mode  

WPH indicates help for Word Perfect users  

Works pace  

 

 
 

 
 

 

 

Tas k l iar  
  

 

 

 

It consists of Start button that is used to start and switch between applications that have been launched  

 

View Buttons   

 

 

 
 

The Word document window consists of four View buttons ï Normal view, Outline Layout view, Page Layout view and 

Outline v iew at the bottom left o f the horizontal scroll bar.  

Ins ertion Point  

It is a tall b linking vert ical cursor that indicates the place where the text or graphics will be p laced when you insert them.  

Mouse Pointer  

 

 

 

 

 

 

 

 

It resembles an I-beam. The pointer changes shape when it passes over certain parts of the Word document window.  

 

Office Assis tant  
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It enables you to type a request and select from a list of possible responses. It also displays context-sensit ive help about  

the current operation. To invoke the Office Assistant, press Fl. To close the Office Assistant altogether, right- click on 

the Office Assistant and select the Hide Assistant from the shortcut menu, or click on the Office Assistant window's 

close button.  

Scroll  Bars  

 

 

 

 

The Word document window consists of two scroll bars - vertical scroll bar and horizontal scro ll bar. The vert ical scro ll 

bar is used to move a document vert ically  while the horizontal scro ll bar is used to  move the document horizontally .  

3.2.2 Menu Bar  

 

 

 

 

It is posit ioned below the title bar. It contains nine opt ions ï File, Edit, Vi ew, Insert, Format, Too ls, Tab le, W indow and 

Help . Each of these menu bar items  has drop-down menus.  

3.2.3 Using The Help  

Word has fo llowing online help :  

¶ Office Assistant  
¶ Topic-specific help   
¶ Point and Shoot help   

Office Assistant  

To open the Office Assistant dialog box:  

1. Click on the Opt ions button shown in  figure above. An Office Assistant d ialog box is  disp layed as shown in figure  

below  

 

 

 
 
 
 

 

 
 

 
 
 
 

 
 

1. Click on the Gallery tab.  

2. Use the Next and Back button to scroll through the available characters  

3. Select an appropriate option, and then click on the OK button.  

 

To search for specific words and phrases:  

1. Click on the Office Assistant or select the Microsoft Word Help option from the Help menu. The Office Assistant is 

displayed on the screen as shown in figure below.  

2. Type a search word or phrase.  

3. Click on the Search button to display a list of possible topics.  

4. Click on the one you think is appropriate 

 

 

 



22 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Topic-Specific Help  

1. Select the Contents and Index option from the Help menu as shown in figure above. A Help Topics window is displayed as 

shown in figure below.  

 
 
 

 
 
 
 

 
 
 
 

 
 
 
 

 
 
 
 

 

2. Double-click on an icon to see a list of subtopics.  

3. Double-click on the topic of interest  

Point and Shoot Help  

To get Online Help:  

1. Select the What's This? Option from the Help menu as shown in Office Assistant option or press Shift + Fl. The mouse 

pointer will become a question mark with an arrow. 

2. Click on the desired item. A pop-up window is displayed on the screen. Now you can read the Help text. To get help on 

another item, press Shift  + Fl again.  

3.2.4 Using The Icons Below Menu Bar  

There are a number of icons below menu bar which can be used to work fast. These icons have been grouped in the form of 

toolbars. Toolbar contain buttons, drop-down menus and other controls that help you alter the appearance and arrangement of 

documents by executing a variety of Word commands. Word provides 16 toolbars that help you perform tasks faster and with 

ease. The most commonly used toolbars are standard and formatting toolbars.  

 

Icons  in S tandar d Toolbar  

  

 

 

The standard toolbar is the one nearest to the top of the Document window and below the menu bar. Standard toolbar 

provides shortcut or menu commands. The left side of the toolbar enables you to perform tasks common to many Windows-

based programs, such as opening a new or existing file, saving or printing a file, cutting and pasting text and objects, and 
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undoing and redoing the most recent actions. The right of the standard toolbar offers some functions more specifi c to word 

application.  

Icons  in For matting Toolbar  

The formatting toolbar contains icons that are common to many Windows programs and related to formatting of text  in  

documents. This includes changing document styles, font, font styles, type styles, paragraph alignments, listing formats, 

indenting levels and borders. Following Table g ives the names and functions of the tools of the formatting toolbar.  

Display Other Icons   

To display or hide tool bars, select the Toolbars option from the View menu of the menu bar as displayed in Figure below.  

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.3 OPENING AND CLOSING DOCUMENTS  

Documents like letters, memo and reports that have already been created can be opened, previewed, and printed with the 

defined marg ins. These documents can be saved with modificat ion at different location. MS Word can automatically save the 

contents of documents at defined intervals.  

3.3.1 Opening Documents  

To open an e xisting docu ment, foll ow these steps :  
1. Select the Open option from the File menu. An Open dialog box will be displayed as shown below.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Select the appropriate drive and fo lder.  

3. Double-click o n  the desired filename to load the document. Alternatively, click on the Open button on the standard toolbar 

or press Ctrl + O.  

4. Select the Window menu. Notice that document names are displayed and the active document has a check mark by it.  

5. Press Esc to release the Window menu. 

To load non-wor d docume nts , fol low thes e s te ps :  

1. Select the Open option from the File menu. The open dialog box gets invoiced as displayed in above Figure.  

2. Select the appropriate drive and fo lder in which the document is located.  

3. Select the type of file you want to view from the Files of type list box.  

4. Double click on the desired File name to load the document.  
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T o ope n a doc ument as  read-only, the s te ps are:  

1. Select the Open option from the File menu. The open dialog box gets invoked as displayed In Figure 4.9.  

2. Select the appropriate drive and folder in  which the document is located.  

3. Select the type of file you want to view from the Files of type box.  

 
 
 

 

 

 

 

 

 

 

4.Click on the down arrow of open button and Select the Open Read-Only option from this drop-down menu.  

 

3.3.2 Save And Save As  

 

When your key in the document is stored in the internal memory of the computer. In order to preserve the document for 

future use, you must save it on the disk. To do so,  

1. Select the Save option from the File menu. The Save As dialog box gets invoked as displayed in figure below:  

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Enter a filename in the File name box and click on the Save button. By default, the new document is saved as a Word 

document with an extension.doc.  

Alternatively, you can click on the save button on the standard toolbar or press Ctrl + S to open the Save As dialog box.  

 

Saving a Fi le i n a S peci fic Location  

 

To save a file in a directory other than the default directory, which is the directory that is highlighted in the directory list of 

the Save As dialog box, select the name of the directory in which you want the document saved and click on the O K  button.  

 

To specify a different drive on which to save your file, fo llow these steps:  

 

¶ Click on the Save in text box In the Save As dialog box. A list of available drives will be displayed. 

¶ Select the drive on which you want to save your file by clicking on it. 

¶ Click on the Save button to complete the process.  

 

Auto s ave Feature  

 

Word has an AutoSave feature which saves your documents after every 10 minutes automatically. To utilize AutoSave for the 

document more often than every 10 minutes, the steps are:  

 

1. Click on the Options button in the Save As dialog box. An Opt ions dialog box is displayed as shown in figure 

below.  
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2. Select the Save tab and select the Save Auto Recover into every option. 

3. Decrease the number of minutes by suing the decrement/Increment button or by typing different number in the text  

box.  

 

3.3.3 Page Setup  

 

Page setup can be used to change page orientation, set left, right, top, bottom margins, pages sizes etc. To change the page 

size and orientation  

 

1. Select the Page Setup option of the File menu. The Page Setup dialog box gets invoked as displayed in the figure below  

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Select the Paper Size tab.  

3. In the Orientation area, select Portrait or Landscape. After selecting, see the Preview area to get an idea of the 

appearance of page with the text. Figure above shows page orientation as Portrait. 

4. Click on the OK button to close the Page Setup dialog box  

 

Setting Margins  

 

1. Select the Page Setup option of the File menu. The Page Setup dialog box gets invoked as displayed in figure below.  

2. Select the Margins Tab. 

3. Enter the measurement in the Top, Bottom, Left, and Right boxes.  

4. Click on the OK button to close the dialog box, When you set marg ins, word applies the measurements to all the pages 

in a document unless you select text or d ivide the document into sections.  
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3.3.4 Pr int Preview  

 

Previewing a document means viewing a screen representation of one or more pages before you print them. To print preview 

a document, the steps are:  

 

1. Select the Print Preview option from the f il e menu. Alternatively, click on the Print Prev iew button on the standard 

toolbar. The Print Preview Window gets invoked as displayed in the given figure:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Use the Magnifier button or select the Zoom option from the view menu to enlarge the document.  

By default, the ruler bar is not displayed in the Print Preview. To ad just marg ins and indents by using the ruler bar. 

1. In the Print Prev iew select the Ruler option from the view menu. 

2. Click the Magnifier button on the toolbar to turn it off.  

3. Position the insertion point in the text you want to format.  

4. Move the mouse pointer until it changes to a black double headed arrow.  

5. Click and drag the arrow left to right (in the horizontal ruler) or up to down (in the vert ical ruler)  

6. Click on the Close button of the Print Preview toolbar to close the print preview window.  

3.3.5 Printing Of Documents  

To print a document, follow these steps:  

1. Select the Print option from the File menu. Alternatively, c lick on the Print toolbar button of the standard toolbar. If 

printer is installed on the computer, Print dialog box gets invoked as displayed in the given figure.  

 

 

 

 

 

 

 

 

 

 

2. In the Name box, select the printer on which your document gets printed. If the printer you use has options you can 

access them by clicking on the Properties option from the File menu.  

3. Click on the Print to file check box to print the document to a file on the disk.  
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4. Enter the number of copies to be printed in the copies area.  

5. To print a range of pages, specify the portion of the document you want to print in the page Range box.  

6. Click on the pages radio button to include the page numbers or the page range, or both.  

7. To print a complete copy o f the document before the first page of the next copy IS printed, click on the Collate check 

box. 

8. If you want to print all the copies of the first page and then print all the copies of subsequent pages, clear the Collate 

check box. 

9. Click on the OK button to send the copies to the printer.  

To print in the reverse order  

1. Select the Options option from the Tools menu.  

2. Select the Print tab in the Opt ions dialog box.  

3. Click: on the Reverse radio button under printing options area. Word prints the document in the reverse order, beginning 

with the last page. Do not select this option when you are printing an envelope. 

4. Select the Draft output check box in the Options dialog box to print a document in draft quality.  

3.4 TEXT  CRE ATI O N AND MANIPULATION  

There are several types of Word documents you can start from like blank document, web page and template. Blank document 

should be used when you want to create a traditional printed document. Use a template when you want to reuse text custom 

toolbars, macros, shortcut keys, styles, and AutoText entries. The text can be copied, moved to a different location. Basic cut, 

copy and Paste features of windows can be used here. Text can be aligned In different ways.  

3.4.1 Document Creation  

MS Word allows you to create a document from the keyboard and save it on the disk. Follow these steps to create a 

document.  

1. Select the New Option from the File menu of the menu bat. A New Dialog box will be displayed as shown below.  

2. Select the General tab in the New dialog box.  

3. Select the Blank Document icon.  
 

 
 
 

 

 

 
 

 

 

 

 
 

4. Click on the Document rad io button In the Crease New Box. To create a new template, click on Template radio button In 

the Create New box. 

5. Click on the OK button. A blank new document is displayed.  

Alternatively, a new document can also be created by clicking on the New button of the standard toolbar or by pressing the 

Ctrl + N combination of keys.  

3.3.2 Editing Text  

This section includes how to insert, delete, modify and copy texts. You can undo or redo- the edits in a Word document by 

using the Undo or Redo options. Before you can start editing, the cursor must be moved to the location where the changes 

have to be made. Fo llowing Table lists the arrow keys used to move around in a document.  

 

Arrow Key  Functions 

Up arrow, Down arrow, Left One character up, down, left  

arrow, Right arrow and right 

Ctrl + Right arrow Next word 

Ctrl + Left arrow Previous word 

Home Beginning of the line 

 En d End of the line 

Ctrl+ Home Beginning of the document 

Ctrl + End End of the document 

Ctrl + Page Up Previous Page 

Ctrl + Page Down Next page 

Figure 4.18 Short  Cut  Keys   
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Word-Wrap Feature  

Consider the following paragraph:  

When the end of the line is reached, Word automatically wrap the text, eliminating the need to press the Enter key until you 

want to start a new paragraph.  

Ins erting Te xt  

Word is normally in the insert mode. The insertion point always stays with the text area. As you type in the text, it  is pushed 

to the right and down. Press insert from the keyboard to put Word back into the insert mode. A character is deleted by 

pressing either the Backspace or Del key. The Del key removes a character from the current cursor position; the Backspace 

key removes the character to the deft of the cursor one position to the left. To insert a line, position the cursor at the 

beginning of the line or at the end of the line and press the Enter key.  

Undoing Edi ts   

The Undo command is used to reverse actions. Suppose you have drawn a circle of radius 4 cm and you decide to delete it. 

Select the Undo option from the Edit menu, or click on the Undo button of the standard toolbar to do so. Alternatively, press 

Ctrl + Z or press Alt + Backspace.  

Redoing Edi ts  

The Redo option is used to reverse the last undo. To redo a change, select the redo option from the Edit menu, or click on the 

Redo button of the Standard toolbar.  

Alternatively, press Ctrl + Y, or Alt + Shift + Backspace  

3.4.3 Text Selection  

Text can be selected by using the mouse, the keyboard, or both. 

To select one word 

Place the Insertion point on the word and double-click on it .  

To select a sentence  

Hold down the Ctrl key while clicking anywhere in the sentence. 

To select a paragraph 

Place the mouse pointer in the selection bar and double-dick on it.  

To select s peci fic text  

Click and drag the l-beam pointer over one character, one word or the entire screen as desired.  

 

3.4.4 Cut, Copy And Paste  

These tools of word are most extensively used to copy, move text from one place to other. To use them text must first be 

selected using any of above-mentioned techniques.  

 

Deleting and Moving Text  

To delete a text from a document, the steps are:  

1. Select  the text to be deleted. 

2. Select the Cut option from the Edit menu, or click on the Cut button of the standard toolbar. Alternatively, select the 

text and press Ctrl + X.  

Moving Text  

To move the text from one point to another, the steps are:  

1. Select the text to be moved.  

2. Select the Cut option from the Edit menu. 

3. Position the insertion point where you want the text to appear. 

4.To paste the text to the required position select the Paste option from the Edit menu, or click on the Paste button of the 

standard toolbar. Alternatively, you can Use CTRL + V to paste the text to the required position.  

Copying Text  

It is possible to copy text to another part of the same document or in a d ifferent document.  

1. Select the text to be copied.  

2.Right click on the highlighted text. A shortcut menu appears near the highlighted text as shown In figure below.  
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3. Select the Copy option from shortcut menu.  

4. Move the insertion point to the location where you want to paste the text.  

5. Select the Paste option from the Edit menu to paste the selected text in the desired location.  

 

3.4.5 Font And Size Selection  

 

Font refers to the manner or style in which text is displayed in the document. Different fonts contain different collection of 

characters and symbols. Word offers many ways to change fonts and font styles. The text to be formatted needs to be selected 

first. Follow these steps to change fonts and font styles:  

 

1. Use the drop- down font list on the format toolbar as displayed in the figure below or type the name of the desired font 

directly into the font name box on the toolbar and press the Enter key.  

 

 

 

 

 

 

 

 

 

 

 

         Figure 3.20 Different Fonts 

 

2. Use Bold (B), Italics (I ), Underline (U) buttons on the format too lbar.  

To add bo ld  formatt ing to  the text , fo llow these steps:  

Select  the text  and click on the Bold  button.  

A lt ernat ively, click on the Bold button and type the text. Similarly, the characters can be underlined and italicized.  

Changing Font Size  

Font s ize is measured in po ints . Po ints and p icas are used for measuring spacing, line th ickness, and so on. There 

are 12 po ints to  a p ica and s ix p icas to  an Inch. Therefore, there are 72 po ints to an Inch. Normal te mplate 

docu ment is 10 po ints Times New Roman, by defau lt. Word o ffers many ways to choose font s izes . To change the 

font  s ize, fo llow these steps :  

¶ Us e the drop-down Front size on the formatt ing too lbars, type the font size in the Font size bo x on the format 

toolbar and press the Enter key.  

¶ Us e any o f these keyboard shortcuts to  increase or decrease the font  size. 

¶ Us e the font  d ialog box.  

Font d ialog bo x contains most comprehensive co llect ion o f formatt ing opt ions. To open the Font  d ialog box,  

fo llow these steps :  

1. Select the font opt ion from the Format menu. A font d ialog bo x gets invoked as d isplayed in f igure g iven below. 

2. Select any opt ion fro m the Font Sty le scro ll list . You can app ly one or more o f these sty les to the selected 

characters and to the subsequent ly typed text . Click on the Regular opt ion to remove the effects. More than one 

style can be combined.  

3. In the Effect area, a b lack check mark on an opt ion ind icates that all the selected text exh ib its that part icu lar 

attribute. A completely clear box for an opt ion ind icates that the selected text does not have the specific att ribute 

and a gray check mark ind icates that some of the text  does not  exh ib it  the character formatt ing opt ion.  

3.4.6 Alignment Of Text  

Alignment is a way o f organ izing the text . It refers to the pos it ion o f the text relat ive to the marg ins. Word enables  

you to left-align, right-align, center-align and just ify the te xt in your document in order to enhance it. Certain lines, 

like the main heading, might need to be center-aligned; subheadings might need to be aligned left . You can do th is 

by using the four formatt ing toolbar buttons as d isp layed in the figure below; Word 's defau lt alignment is left  

alignment. It is a good po licy  as it p rov ides space to center your text. Type the text at left marg in and press the 

Center button to  center your text .  

 

 

Right-Aligned Text  

Te xt is said to be right-aligned if it is aligned with the right marg in o f the page. To right -align a paragraph, position 

the cursor on any line with in the paragraph and click on the A lign Right  button on the Formatt ing too lbar.  
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Left -Al igned Text  

Te xt is said to  be left-aligned if it  is aligned with the left - margin o f the page. Th is is the defau lt mode of 

alignment. To left-align a paragraph, pos it ion the cursor on any line within the paragraph, and click on the A lign 

Left  button on the Formatt ing too lbar as d isp layed in  the figure o f A lign ing Text  paragraph.  

Centered Text  

The Center opt ion is normally used to center the heading and text . To center a line o f text , posit ion the cursor on 

the line and click on the Center button on the formatt ing toolbar.  

Justi fied Text  

This feature aligns a paragraph with both the left and the right marg ins. Inter-word spacing is adjusted such that  

each line o f text beg ins at the left marg in  and ends at the right marg in. To just ify a line o f text , posit ion the cursor 

on the line and click on the Just ify button on the formatt ing too l bar. Figure below illustrates  d ifferent align ments .  

 
 

 

 

 

3.5 FORMAT TING THE T EXT  

Text that has been written can now be made elegant with the help of formatting. Bu llets and numbers highlight the portions 

that you want to highlight.  

3.5.1 Paragraph Indenting  

 In Word, each time you press the Enter key you create a new paragraph. Word paragraph always end with a paragraph mark. 

When you open a new document, the default paragraph setting stored as a style (Normal) is applied. You can press Shift + 

Enter combination of keys to force new lines without starting a new paragraph.  

Line Spacing  

Spacing can be used to design your document and make it more readable. The default spacing is single. Word enables you to 

change the line spacing in your text. You can set spacing to single, double or one and half lines. To set the line spacing, 

follow these steps:  

1. Select the paragraph option on the Format menu. The paragraph dialog box gets invoked as displayed in given figure.  

2. Select the Indents and Spacing tab. 

3. Select an option from the line spacing drop-down list. 

4. Select a value from the at list box. 

5. Click on the OK button to close the dialog box. See the Preview area for getting an idea of the formatted text.  

 
Paragraph Spacing  

You can define the amount of white space placed before and after paragraphs by giving values in the spacing area of 

paragraph dialog box.  

Indenting Text  

Indenting is making your text look more eye-catching. Indents are added to marg ins, thereby increasing the white space and 

decreasing the text area for specific paragraphs. To set the Indents for text  by using the dialog box  

1. Enter the specification for left, right and/or first line Indents in the Indentation area of paragraph dialog box.  

2. Select an option from the Special drop-down list.  

3. Click on the OK button. Every paragraph in the document will have the same Indentation settings. 
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Hanging Indents  

 

When you create a bulleted list, numbered paragraphs or bibliography, you want the first line of every paragraph to stick out. 

The first line in a hanging Indent is called a Hanging Indent. The subsequent lines beneath are called turnover lines. Word 

can also create hanging Indents for bulleted and numbered lists.  

 

Creating Hanging Indents  Using a Ruler  

To create hanging indents by using the ruler; you need to follow the steps listed hereunder:  

1. Place the insertion point in the paragraph you need to format, or select mult iple paragraphs.  

2. Drag the button half o f the left Indent marker to the tight. This will set the position of the left (Indented) edge of the 

turnover lines.  

3. Drag the top half of the left Indent marker to the left past the turnover Indent.  

4. Release the mouse button when you reach the desired for creating the hanging Indent. The hanging indent is created. 

Figure Illustrates the hanging indents.  

    

Creat i ng Hanging Indents  Usi ng Keyboar d Short cuts  

 

There are keyboard shortcuts for moving the left - Indent. Movements in the increments are used for default tab settings 

(usually 0.5 inch). Press Ctrl + N  to move the left tab marker to the right marg in. Press Ctrl + Shift + N  to move the marker 

to the left marg in.  

3.5.2 Bullets And Numbering  

 

You can use bullets and numbers to make the lists in your document attractive and easy to read. You can bullet or number 

your lists by using either the formatting toolbar buttons or the automatic formatting feature.  

To get bullets  or numbers automatically as  you type your lis t:  

1. Type an asterisk (*) and a space or a tab. 

2. Enter text and press the Enter key. Word turns the asterisk into a bullet and sets the spacing. In the same way you can 

do for numbered lists. You can also bullet a paragraph by clicking on the bullet list button.  

To change the bullet style, follow these steps:  

1. Type a list of your favorite authors. 

2. Select the Bullets and Numbering option of the Format menu. The Bullets and Numbering dialog box gets invoked as 

displayed in figure below.  
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3. Click on the Bulleted tab in the Bullets and Numbering dialog box.  

4. Click to select a style of your choice.  

5. Click on the OK  button.  

 

To s peci fy cus tom bullets , foll ow thes e steps :  

 

1. Click on the Customize button in the Bullets and Numbering dialog box. The Customize Bulleted list dialog box is 

displayed as shown in figure below. 

   
  

2.  Change the bullet and text positions according to your requirement. 

3.  Select the bullet from the Bullet character list. The Symbol dialog box gets invoked as displayed in figure below.  

 

 

  
4. To use bullets not shown in the Bullet Character box, click on the Bullet button. 

5. Click on the Font button to select the font you want to apply to your text.  

6. Click on the OK button to dose tile Customize Bulleted List dialog box. 

7. Click on the OK button to close the Bullets and Numbering dialog box.  

 

3.5.3 Changing Case  

 

To convert  the cas e o f the te xt  you have ins erted fo llowed these steps :  

1. Select the text you want to change  

2. Select the Change Case option from the format menu.  

 

A change case dialog box is displayed on the screen as shown below:  

 

 
The Change case dialog box has the following options:  

 

Sentence case: capitalize only the first letter in the selected sentences.  

lower case: converts all selected text to lowercase letters.  

UPPER CASE: converts all selected text to uppercase letters.  

Title Case: cap italizes the first letter of each word of the selected text.  

tOGGLE cASE: changes uppercase to lowercase and lowercase to uppercase in all selected text.  

 

3.6 TABLE MANIPULATION  

 

Tables are made up of rows and columns, Rows are the horizontal lines, columns are vertical lines and their intersection 

makes a cell. The content of cell can be formatted with the same methods as are used to format any text.  

3.6.1 Draw Table  

To create a tab le, fo llo w thes e s teps :  

1. Place the Insertion point where you want to place the table.  

2. Select the Insert Table option from the Table menu. Alternatively, click on the Insert table button of the standard 

toolbar and drag the mouse over the palette to create a table with the highlighted number of rows and columns. The 

Insert Table dialog box is invoked which is shown below.  

 

 



33 

 

 

3. In the Insert Table dialog box, select any of the following options to define the contents of the table:  

¶ In the Number of columns text box, define the number of columns in the table.  

¶ In the Number of rows text box, define the number of rows in the table. 

¶ Click on the AutoFormat button. A Table AutoFormat dialog box gets invoked as displayed in the figure below.  
 

 

The Table Auto format dialog box lets you select the style of the table you want to create.  

 

Alternatively, fo llow these steps:  

 

1. Position the Insertion point in the table. 

2. Select the Table AutoFormat option from the Table menu. The Table AutoFormat dialog box gets invoked as 

displayed above.  

3. Select one of the predefined borders and shading formats for the table the Formats scroll list box. 

4. In the Format to apply area, select the Auto Fit check box to automatically adjust the size of the table to fit  its 

contents.  

5. In the Format to apply area, select the corresponding check box to apply Borders, Shading, Font or Color specified 

in the format.  

6. In the Apply special formats to area, select the corresponding check box to apply the special formats. The Table is 

formatted as per requirements.  

 

3.6.2 Changing Cell Width And Height  

 

Cell width and height can be changed in several ways.  

 

To Change the column/row Width/height in  a table  

Rest the pointer on the column/row boundary you want to move until it becomes a vertically parallel lines, and then drag 

the boundary until the column/row becomes of the width/height you want.  

To change a column/row width/height to a specific measurement  

1. Click a cell in the column/row.  

2. On the Table menu, click Table Properties, and then click the Column/row tab.  

3. Choose the options you want.  

To make the columns/row in a table automatically fit the contents  

1. Click a tab le  

2. Point to Auto Fit on the Table menu  

3. Click Auto Fit to Contents.  

To display column width measurements click a cell and then hold down ALT as you drag the markers on the ruler.  

 

3.6.3 Alignment Of Text In Cell   

The text in the cell can also be aligned with the same process as normal text. First of all select the text in table and then 

click on the desired alignment icon. Selecting text in a table is similar to selecting text in a document. You can drag the I-

beam pointer over the text to select i t , or d ick on the selection bar to select an entire row.  

Some specified techniques to select text in a table are as follows:  

¶ To select one cell, t rip le-click on that cell, or click on the left  inside edge of the cell. 

¶ Select an entire row by clicking on the selection bar to the left of the table; drag up or down to select more than one 

row. 

¶ To select an entire column, place the mouse at the top of the column. The pointer changes to a black down arrow, 

Click on it  to select the column.  

¶ To select the entire table, place the insertion point in the table and select the Select Table option from the Table 

menu.  
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3.6.4 Delete Iinsertion Of Row And Column  

The table's format can be changed to fit the data that is to be displayed in the table. You can add or delete rows and 

columns in a table as per your requirements.  

To Delete Cells  

1. Select the cells to be deleted. 

2. Select the Delete Cells option from the Table menu. The Delete Cells dialogue box is as below: 

 

 

3. Select one of the following options in the Delete Cells dialog box:  

¶ Select the Shift cells left rad io button to move the cells in the row to the left of the deletion.  

¶ Select the Shift cells up radio button to move the cells in the column up after the deletion. 

¶ Select the Delete entire row radio button to delete the row that contains the selected cell. 

¶ Select the Delete entire column  radio button to delete the column that contains the selected cell. 

To delete a row  

1. Select the row to be deleted.  

2. Select the Delete Rows option from the Table menu.  

To delete a column  

1. Select the column to be deleted. 

2. Select the Delete columns option from the Table menu.  

Inserting Rows and Columns  

To insert a row in the table, follow these steps:  

1. Place the insertion point in the row below where you want the new row.  

2. Select the Insert rows option from the Table menu. Alternatively, click on the Insert Rows button of the standard  

toolbar.  

You can also use either of the following methods to add a row or column:  

¶ With the Insertion point in  the last cell, p ress Tab to add another row at the end of a tab le .  

¶ Select the right side or the column and select the Insert Column option from the shortcut menu (Right-click on the 

mouse button to invoke the shortcut menu) as displayed in the figure given below: 

 

3.6.5 Borders And Shading  

By default, table borders are inserted when you insert a table in a document. They get printed with the document. If the 

default is removed, the table's gridlines are displayed. Grid lines are non-printing characters and get printed with tile 

document. You can select the Hide Grid lines or show Grid lines option from the Table menu to toggle the display of 

gridlines in a table on the screen. Word has many paragraph and border shading features. You call apply borders and 

shading to single paragraph or to a group of paragraphs.  

To change border to a specific type:  

1. Click a cell in the co lumn/row. 

2. On the Table menu, click Table Properties, and then click the Border and Shading tab, Choose the options you 

want.  

 

Check  Your Progress   

Q1. How to start MS-WORD?  

Q2.  Why we use Office Assistant?'  

Q3.  What does Standard Toolbar provides?  

Q4.  How do you create documents?  

Q5.  How do you save document?  

 

3.7 SUMMARY  

¶ Microsoft office is a software package that offers new features for sharing data and documents, better-than-ever 

communicat ion tools, internet/Int ranet  access and publishing capabilities.  

¶ There are many ways to start Microsoft Word. The most common are the Win2K Start Menu or the Office shortcut 

bar.  

 

¶ The basic components of the default Word screen are:  

Title bar; Menu bar, Ruler bar, Status bar, Workspace, Taskbar, View buttons, Insertion point  

¶ Word's file finding utility helps you to locate, list, sort, examine, open and print doc.uments on simple and complex  

criteria.  

¶ Word has three kinds of Online help: Office Assistant, Topic-specific Help, Point and Shoot Help  
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¶ Word automatically wraps the text, eliminating the need to press the Enter key until you want to start a new 

paragraph.  

¶ Select the Cut/copy option from the Edit menu to delete/copy text. 

¶ Select the Paste option from the Edit menu to move the text from one point to another.  

¶ Select the Change Case option from the Format menu to change the text case.  
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CHAPTER 4: SPREAD SHEET 

4.0 INTRODUCTION  

 
MS Excel is an electronic spreadsheet. A spreadsheet is a generic term for the software package that simulates a paper 

worksheet often used by people in management. Most spreadsheets started as electronic versions of hard copy accounting 

worksheets with one major purpose - simple row and column arithmet ic. It has various features to offer namely, fast 

calculations, what-if analysis, charts (also called graphs), automatic recalculat ions, and many more.  

A variety of applications for which MS-Excel can be used include automating financial statements. Excel comes across as a 

powerful and flexib le graphical presentation too1. Data stored in database formats can be accessed through MS-Excel. 

Graphs or charts can be created based on data for quick assessment of a situation.  

4.1 OBJECTIVES  

After going through this unit, you will be ab le to:  

¶ Understand the features of Excel;  

¶ Navigate worksheets;  

¶ Make different types of entries in a worksheet;  

¶ Create text, numbers & date series;  

¶ Manipulate cells  

¶ Create s mall budgets/ sales reports  

 

4.2 BASICS OF SPREAD SHEET  

When you start Excel, workbook is displayed. It is here that Excel stores all its data and allows manipulat ion. A workbook 

is a collection of individual worksheets, each of which can hold data. All actions and operations of Excel take place in the 

worksheet. Excel has 65536 rows and 256 co lumns in its worksheets.  

 

4.2.1 Opening Of Spread Sheet  

Microsoft Excel can be started in fo llowing way:  

1. Click on the start button in the Windows environment.  

2. Select Programs option from the Start menu.  

3. Select Microsoft Excel option from the Programs submenu. The following screen is displayed. 

  
It has user Interface features common to other Microsoft Office Applications. Each worksheet is made up of cells that are 

the basic units for storing data.  

 

Naming The Sheets  

Excel has its worksheets named as sheet1, sheet2, sheet3, and so on. Sheets can be given other names which may prove to 

be more convenient for task identifications; for example, workbook1 may contain sheets called Student, Mark sheet, 

Attendance, and so on.  

To name a sheet, follow the steps:  

1. Double-click the sheet tab to which you want to give a new name. 

2. The Rename dialog box gets invoked where the new name can be specified. 

3. Or you could go to the sheet tab and click on the right mouse button. 

4. Select Rename.  

Once the dialog box is displayed, give the new name and click on the OK button. 

  

4.2.2 Addressing Of Cells  

Each worksheet is made up of cells, and cells are a result of Intersect ion of rows and co lumns. They are the basic units for 

storing data. Each cell gets its name from this Intersection. The address of a cell that is in column A and has its row number 

as 4 is referred to as cell A4. A group of contiguous cells is called a range. An example of a cell range would be G1: G3.  

Cell Al, A2 contains the label Chandan, Yashpal.  

Cells B4 and C4 contain the value 400  and 800 respectively.  

Cell G4 contains the formula: C4-B4.  

Pressing the Enter key will result in G4 ho lding the result of the formula = (C4-B4).  

All formula entries should begin with an = (equal to) sign.  

You can make a cell active by Clicking on it. Files created by a spreadsheet package are known as worksheets. Automatic 

recalculat ion feature hastens the calculation tasks. If data in cell C4 is changed from 800 to 900, then the formula in cell G4 

would calculate the result based on the new C4 cell content. This is due to the fact that, once the formula is created with 

cell references in it, it establishes a relationship with the specified cell references or addresses. You can move around in a 

worksheet with the aid of a mouse or the keyboard, or by using the menu bars, You can use the arrow keys, Page Up, Page 

Down and a host of other keys in combination, to move around in the worksheet.  

To move in the works heet by using the Menu bar :  

Select the Go To option from the Edit menu or press the F5 function key to open up the Go To dialog box and E2, Type the 

reference of the cell, c lick on the OK button of the Go To dialog box. The cell pointer moves to Cell E2 Immediately.  

To move to the works heet using the Mouse:  

Select the cell you want to activate. Place the mouse pointer on It. Click to activate it . Several cells can be grouped to form 

a cell range. Cell ranges are required to be selected for calculation, and clicking on each one of them becomes a very 

tedious task. Cells can be selected using keyboard, mouse. To select a cell range for an instance, you can do the following:  
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Usi ng Keyboard  

1. Move the cell pointer at the corner of the cell range which you want to select. 

2. Click on the starting cell o f the range.  

3. Press and hold down the Shift key and then press the arrow keys to select the range.  

Us ing Mous e  

1. Click on a corner of the range you want to select.  

2. Drag the mouse over the range.  

3. When you reach the end of the range, release the mouse button (refer figure).  

 
4.2.3 Printing Of Spread Sheet  

Excel offers you various printing options for your worksheets. It enables you to have a preview of worksheet data with the 

aid of the Print Preview option. You can set margins, fonts, headers and footers to enhance your worksheets.  

Printing an Area  

By default, Excel prints the current worksheet when the Print command is selected from the File menu. However, if you 

require a part icular area of the worksheet to be printed, then you are offered this facility also. To do so, you can follow 

these steps:  

1. Select the range that you want to print.  

2. Select the Print option from the File menu. The Print dialog box gets invoked as shown in figure below.  

 
3. In the Print What section of the dialog box, choose the Selection option.  

4. Select the OK option to complete the procedure.  

Defining and Deleting a Print Area  

There may be situations where you need to print the same range repeatedly. To avoid the tedium of specifying the same 

range for printing several times, you can conveniently define range as the print area.  

1. Select the area you want to specify.  

2. Select the Print Area option from the File menu.  

3. Select the Set Print Area from the Print Area submenu as shown in the figure below.  

 
4. Select the Print option from the File menu.  

5. Click on the OK button.  

6. You can select Clear Print Area when you want to remove the defined Print Area.  

Printing Worksheets  

Worksheets can be very conveniently printed by the use of the Print command that sends your worksheet pages to the 

printer Immed1ately.  

To print worksheets, the steps are:  
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1. Select the Print  opt ion from the File menu. Th is invokes the Print d ialog box.  

2. This dialog box is very similar as you used in the MS-Word Print d ialog box. The on ly d ifference is the three 

extra - button which are given below:  

Selection - prints selected cells.  

Active sheet(s ) - prints only  selected worksheets.  

Entire Workbook - prints open workbook.  

De vice O ptions : Controls the print quality and allows you to ad just Printer me mory t racking (this affects how the 

driver t racks  printer memory usage)  

4.2.4 Saving W orkbooks  

Whenever workbooks are created, they are named, by defau lt as Workbook1, Workbook2, and so on. Sav ing the 

worksheets of these workbooks makes them permanent. To save the work on your worksheets, you should fo llow 

the steps:  

 
1. Select the Save option from the file menu to save it on the d isk.  

2. You can also click on the Save button on the standard too lbar.  

3. Name the file you have saved and specify the locat ion at which the workbook should  be p laced.  

Saving Mul ti ple Fil es  

When you have a number of files that are open, you can very conveniently save them all. You can select the Exit  

option from the File menu and click on the óYes  to A ll ô button in  the Save As d ialog box that is d isp layed.  

Saving As  an HT ML  Fi le  

Excel allows you to pub lish your workbook data on the Web and even move to other flies by  using hyperlinks. You 

can also save an Excel worksheet as an HTML file for pub lishing on the World W ide Web. To do so, you can select  

the Save as HTM L opt ion.  

4.3 MANIP ULATION OF CELLS   

Active cell is ind icated by a rectang le boundary over that cell. Data entry is accomplished by feed ing the data in the 

active cell. A1 is always the act ive cell in a new worksheet by default , but if you want to move on to another cell for 

data entry , then you can make that cell act ive by moving the mouse pointer on it and clicking on it. As you type, the 

data is d isp layed in the active cel l  as well as in  the formula bar.  

   

 

 

 

There are three boxes  that exist  between the Formula Bar and the Name Box.  
The first box with across (x) symbol cancels your entry made in the cell.  
The second bo x with  a right  mark allows acceptance, o f data in  the cell.  
The third  box contains an equal to  (=) s ign. Th is is the Edit fo rmula feature that s implifies the calcu lat ion tas ks  

4.3.1 Entering Text, Numbers And Dates  

Entering Text  

Text entries can be numbers, letters or symbols. Numbers can also be treated as text, especially in cases where 

calculations are not requ ired; for example, telephone numbers" record numbers, zip codes, ro ll numbers, and so on. 

Excel studies the entered data to determine the type. If you type an address which is alpha-numeric in nature, it is 

automat ically taken as a text entry; fo r example, Electron ics Niketan, 6 CGO Complex, New Delh i -110003. Numeric 

entries that are to be treated as text should  be preceded with an apostrophe: for example. '64. It is then considered as 

te xt entry .  

En tering Num bers   

Numeric entries are constants and can be integers, decimal fract ions, integer fractions and scientific notat ions. For 

example (9.994E+0.05). If #### symbol occurs when you make a numeric entry, it  implies that the number is very  

long and the co lumn width  not wide enough to accommodate it .  

Entering Date and Time  

Date and time entries can also be made In Excel worksheets. Excel allows calcu lat ion on dates because it  converts the 

entry to a serial date number; for exa mple, you can find out the age of a person by reducing the current date from h is 

date of b irth. Excel recognizes da e and time on ly when they are specified in the right formats. The valid formats for 

the date and t ime are:  

Valid  Date and valid  t ime format  

6/10/ , 6-0CT-, 6-0CT, OCT-612:30, 12:30:20, 2:30 AM  

4.3.2 Creating Text, Number And Date Series  

You may sometimes find yourself in  a situat ion where you need to  key in a series of text, dates, t ime or numbers. A 

time series, for example, can include Increments of days, weeks or months. It  can include repeat ing sequences such as 

weekdays, month names or quarters. In such cases, specify ing the in it ial t ime select ions and the last value o f the 

series would resu lt in the ent ire series being generated automatically by Excel. A few examples of time series have 

been g iven below:  

 In itial Select ion  Extend Series  

 1, 2  10:00, 11:00, 12:00  
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 Man  Tue, Wed, Thursday  

 Jan  Feb, Mar, Apr  

You can also generate linear series and growth series by select ing the in it ial values for the series and pos ition ing 

them in  the first two cells o f the range of cells to be generated. Examples o f linear and growth series are g iven below:  

In itial So lution   Extended linear series  

1, 2    3, 4, 5 

100, 95    90, 85 

1, 3   5, 7, 9  

¶ Auto Fill feature (Auto Fill  handle) is the s mall p lus s ign at  the bottom right comer of the act ive cell.  

¶ Menu bar  

¶ Shortcut menu  

Creating Text Series  

To fill a range of cells with text entries, such as days, months, and so on, or fill a range of cells with text using the 

AutoFill feature, follow the steps:  

1. Enter the first value in the cell wh ich would be at the beginning of the series, and select the cell.  

 
2. Drag the Auto fill  handle across the cell that you want to  fill. 

3. Release the mouse button. 

4. Excel files the range of selected cells with  the appropriate text  entries.  

Use the menu bar to perform the sam e task by fo llowing these steps:   

1. Enter the first value and select the range to be filled.  

2. Select the fill option from the Edit menu  

3. Select the Series option from the Fill submenu.  

 
4. Indicate whether you want to fi ll your series in rows or columns.  

5. Specify the type of series you want you create - linear, Growth, Date or AutoFill.  

6. You can now specify the start and the stop values.  

7. You can create series such as:  

 

4:00, 5:00, 6:00, 7 :00  

Redg100, Redg101, Redg102  

Jan, Feb, Mar  

Sun, Mon, Tue  

North, South, East, West  

 

The method for entering series of dates, series of numbers is same as given above. You can enter a series of numbers or 

series of dates where increments and decrements of numbers is by a specific value. Suppose you want to generate a list of 

even numbers. You can do it  in the following ways:  

Us ing the Auto fil l Feature  

1. Enter the number 2 or any date in the first cell and the number 4 or any other date in the second cell.  

2. Select both the cells.  

3. Drag the Auto Fil l  handle over the range of cells you want to fill.  

4. Release the mouse b utton.  

Excel fills the range of cells with the appropriate entries,  

You can also use the Series option from the Fill submenu of the Edit menu for generating a series of numbers.  

 

4.3.3 Editing Worksheet Data  

The data that exists in cells may require some ed iting, such as moving data from one location to the other, clearing cell 

contents, and so on. You can edit the contents of the cell by using the formula bar or the In-Cel l edit ing option as described 

below:  

For mula Bar Method  

1. Select the cell you want to edit.  

2. Click on the formula bar or press the F2 function key.  

The contents of the cell get displayed in the formula bar which can be edited accordingly.  

In -Cell  Edi ting  

To edit the contents of a cell:  

The Insertion poi nt  appears at the end of the cell which can be moved to the required position for editing,  

Clearing a Cell  

To clear a cell is to erase the cell content but it is not similar to delet ing a cell. Deleting a cell o r cells causes the other cells 

on the right or bottom to shift: positions. Clearing cells, on the other hand, does not cause the other cells to shift. There are 

different ways of clearing cell contents.  

(i) To clear a cell using shortcut menu:  

1. Highlight the cell or range of cells to be cleared.  

2. Click on the right mouse button.  
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3. Select the Clear Contents from the shortcut menu.   

 
(ii)To clear the cell contents by us ing the Delete key, fo llow the steps:  

 

1. Select the cell and use the Delete key to clear a cell.  

2. Excel clears all the data from the cell, but does not  change cell formatting.  

 

(iii )To clear the contents of a cell using menu bar, fo llow the steps:  

1. Select the cell or range of cell.  

2. Select  the Clear opt ion from the Edit  menu. 

3. The submenu that  appears has the opt ions:  

¶ Contents - clears the cell contents  

¶ Comments - clears the comments in  the cell  

¶ All - to clear everyth ing from the cell, including formatt ing and cell Notes.  

¶ Formats - to dear on ly  cell fo rmatting from the cell.  
 

Copying Data  
 

To create mult ip le copies of worksheet data, you use the Copy and Paste feature o f Excel. This makes it easier to copy 

the contents of the cells than typing the data all over again. The task can be accomplished in several ways.  

(I) Using the menu bar, you need to:  

 

1. Select  the cell o r range of cells hav ing the cell contents that are to be cop ied.  

2. Select  the Copy opt ion from the Edit  menu.  

3. Select  the cells in  which you want to paste a copy of the data.  

4. Select  the Paste opt ion from the Edit  menu or press Ctr l + V   

 
(II ) You can use the shortcut menu to copy and paste by fo llowing the steps:  

1. Select  the range of data that you want  to copy.  

2. Click on the right mouse button.  

3. Select  Copy from the shortcut  menu  

4. Select  the cells in  which you want  to paste your data.  

5. Click on the right mouse button again and select the Paste opt ion from the shortcut menu.  

 

(III) Drag and Drop Method  

To use the drag and drop method to copy and paste data, fo llow these steps:  

1. Select the cells you want  to move.  

2. Point to an outside edge of the selected range by using the mouse.  

3. Click on the selection, press the mouse button and drag the cells to a new location and then release the mouse 

button.  

(IV) The AutoFill command enables you to copy contents to adjacent cells. To do so, you can follow the steps;  

1. Select the cell or range of cells that contains the data you want to copy.  

2. Position the mouse pointer on the fill handle.  

3. Drag the Fill handle over the adjacent cells. 

4. The cell contents would be copied in the adjacent cells.  

5. Release the mouse button  

Cut and Pas te  

When you select the Cut command to  move the data, a copy o f the data is stored in the window Clipboard. Later when 

you use the Paste option the data is placed 1n another area of the worksheet. The method for performing cut & paste is 

similar to copy except the fact that instead of copy, cut is selected from menu.  

 

4.3.4 Inserting And Deleting Rows, Column  

You can insert rows, columns, and cell ranges, if required. Insertion of rows, columns, and cell ranges always cause the 

data already in the worksheet to shift position to accommodate the inserted object. The method for deleting/inserting rows/ 

columns is similar to deletion/insertion of cell except that new cell is to be selected.  

1(a) To insert a column using the main menu, the steps are:  

¶ Position the cell pointer on the column where you want the new column should be inserted. Select the Column 

opt ion from the Insert menu. 

¶ Excel inserts a new column and, the existing columns shift to the right.  
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1(b)To insert a column using the shortcut menu, the steps are:  

¶ Position the cell pointer in the column where you want your new column should be inserted.  

¶ Click on the right mouse button on the column header and select the insert option from the shortcut menu as shown 

in Figure below:  

 
2(a) To delete a column using the main menu, the s teps  are:  

¶ Click the letter of the column you want to delete. Select the Delete option from the Edit menu.  

 

2(b) To delete a column us ing the shortcut method, the s te ps are:  

¶ Select the letter of' the column you want to delete. Click on the right mouse button and select the delete option from 

the shortcut menu.  

3(a) To ins ert a row using the main me nu, the s te ps  are:  

¶ Select a cell in the row below the location where the new row should appear. Select the row option from the insert 

menu.  

3(b) To ins ert a row using the s hortc ut menu, the s teps  are:  

¶ Select a cell in the row below where the new row should appear.  

¶ Click the right mouse button on the row header and then select Insert option from the shortcut menu.  

4(a) To delete a row using the main menu, the s te ps are:  

¶ Select the row which you want to delete. Select the Delete option from the Edit menu.  

4(b)To delete a row using the shortcut menu, the s teps  are:  

¶ Select the row which you want to delete. 

¶ Click the right mouse button and select the Delete option from the Shortcut menu.  

 

4.3.5 Changing Cell Height And Width  

The data that you enter in the cells is sometimes too long for the column width to accommodate. You can increase the 

column width and row height to display the entire cell entry.  

Changing Column Width  

Column width can be changed by using the mouse or the menu commands.  

(i)  To change column width using mouse 

1. Position the mouse pointer on the right border of the heading of the column that: has the width to be changed.  

2. Press the mouse button and drag it to the right to increase the column width or towards the left to decrease the width.  

3. Once the right width has been selected, release the mouse button. 

(i i) To change the column width using the menu bar, the steps are:  

1. Click on the heading of the column that has the width you want to change.  

2. Select the Column option from the Format menu.  

3. Select the Width option from the Column submenu.  

      
4. Enter the column width in the column width text box.  

5. Select the OK option.  

Changing Row height  

Change the row height by using the mouse and the menu bar.  

(i)To change the row height by using the mouse, the steps are:  

1. Position the mouse pointer on the heading of the row (where the row numbers are specif ied) having the height you 

want to change. 

2. Press the mouse button. A double headed arrow is displayed.  

3. Drag the arrow down or up to increase or decrease the row height. 

4. Release the mouse button when the appropriate height is selected.  

(ii) To change the row height by using the menu bar, the steps are:  

1. Click on the heading of the row whose height you want to change.  

2. Select the Row option from the Row submenu.  
3. Select the Height option from the Row submenu.  

4. Enter the row height in the Row Height text box.  

5. Select the OK option.  

A sample of increased column width and row height has been shown in the Figure. 

4.4 FUNCTIONS AND CHARTS  

Excel uses formulas for calculations. Formulas can be simple as well as complex in nature. Charts are introduced in 

worksheets to make analysis tasks easier. Charts are an effective way of representing value through the visual presentation 

aid. They not only enhance the look of the worksheet but also allow a user to gather a lot of In formation in much lesser 

time.  

4.4.1 Using Formulas  

Entering Formulas  

Using a formula, expressions can be calculated by typing the formula in the appropriate cell; for example, = B4+C5 is a 
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formula that adds the cell content of cell B4 to the cell contents of cell C5. The formula must be preceded by an equal to 

(=) sign.  

= 35*44  

= 23 ^ 2  

= C5 - C3  

= C1 + C2 + C3 + C4 + C5  

= S3 - D6 * 44/3  

 

Formulas can also contain named cells or cell ranges. Excel formula functionalities lie in the fact that It can relate the 

formula to the cells referred in it  and, i f the contents of these cells change, a new result is calculated with the aid o f the 

automatic recalculat ion feature. The formula entered in an active cell is also displayed in the formula bar as you enter It. To 

display the result of the calculated expression in the active cell, press the Enter key. It is to observe that the cell displays 

the result, and the formula bar displays the formula or expression.  

4.4.2 Using Functions  

Functions are predefined formulas that perform calcu lations by using specified values called arguments in a part icular 

order, called the syntax; for example, the SUM function adds the values or ranges of cell.  

To enter a formula that contains a function, follow the steps:  

1. Click on the cell in which you want to enter the formula  

2. To start the formula with the function, click on the Edit Formula button in the formula bar.  

3. Click on the down arrow head right next to the functions box to invoke a drop-down list of available functions, 

which Include SUM, CO U NT, AVERAGE, MAX, and so on.  

4. Click on the function you want to add to the formula. If the function does not appear in the list, click on More 

Functions.  

5. Enter the arguments for the function.  

6. When you complete the formula, press the Enter key.  

 

The other convenient way of choosing functions is by using the Paste function that appears on the standard toolbar as fx 

symbol.  

 
You can also select the Function option from the Insert menu to select an Excel function. Both the actions Invoke the Paste 

Function dialog box.  

 
The Function category list displays Excel's built-in functions. Select the required function from the list. If you are not sure 

which function to select, there is a Help button in the Office Assistant to guide you.  

 

Check Your Progress  

Fill in the blank area, with the corresponding terms or phrases:  

1. _______________Provides the informat ion about the settings that are currently being used as; well as for date & t ime.  

2.  ___________A group of cel ls on which a ope rat ion is to be perform ed. 

3.  __________ ____A commonly used calcu lation that is built in to the spreadsheet. 

4.  ___________Designates the intersection of a row and column. 

5.  ___________ contains the main menu and the edit  menu. 

6.  ___________A number that can be used in mathematical operation. 

7.  ___________indicates for operation currently being performed. 

8.  ____________An equation entered into the spreadsheet by the user.  

9. ___________The Area where data can be entered or changed.  

 

4.5 SUMMARY  

Spreadsheet is software that simulates a paper worksheet. MS Excel is a W indows-based spreadsheet package. Movement 

in a worksheet is possible by using the keyboard, mouse or the scrollbars. Data entry can be of text, numbers, date, and time. 

Series of text, numbers, dates and time can be conveniently created. Saving a workbook saves all the worksheets contained 

In It. Worksheets can also be saved in different formats. Making modificat ion in worksheet is possible. Ed iting a cell or a 

cell range can do it. Copying and moving data from one place to another in a worksheet can be done. Worksheets can be 

inserted and renamed, and deletion of these worksheets is also permitted. Column width can be changed by using the 

format column and Width options. Row height can be altered by using format row and height option. Charts can be 

embedded in  your worksheets by using the Chart Wizard feature of Excel.    

 

4.6 MODEL ANSWERS  

1. status line  
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2. Range  

3. Function  

4. Cell  address  

5. Control Panel  

6. Value 

7. Operating mode  

8. Formula 

9. Active Cell  
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CHAPTER 5: COMMUNICATION USING INTER NET  

 

5.0 INTRODUCTION  

Computers in organizat ions have been used to extract and correlate information. Resource sharing, high reliability and 

communicat ion can be achieved by connecting these computers. Computer Networks offer better price / performance rat io 

over mainframe computers. Network also delivers services to Individuals like access to remote informat ion, pay their bills, 

manage their bank accounts and handle their investments electronically. World W ide Web contains Information about 

almost everything. Another important category of network use is person to person interaction and Email is already widely 

used by millions of people and now also contains audio video besides text. Irrespective of i ts place, Internet can be used 

for a number of purposes like accessing World Wide Web, email etc.  

5.1 OBJECTIVES  

After completing this lesson you will be able to   

Å Know tile different concepts of Local Area Networks. 

Å Become me familiar wi t h WAN terminology.  

¶ Learn about dif ferent types of WAN connections.  

¶ Configure the Ethernet Card.  

¶ Configure Modem card for Dial up.  

¶ Know about different protocols and terms used in Internet  

5.2 BASICS OF COMPUTER NETWORKS  

The merging of Computers and communications has had a profound influence on the way Computer systems are organized. 

The old model of a single main frame computer service all of organizations needs has been replaced by one in which a large 

number of separate but interconnected computers do the job. These systems called Computer networks.  

5.2.1 Local Area Network (LAN)  

Local Area Network as the word itself defines, is a network confined to a small area. It is a network of Computers that is 

privately owned and limited to a small room, single bu ild ing or at most spread across the campus. There are three 

characteristics of LANs, which distinguish them from other types of networks. i) Size, ii) Transmission Technology, iii) 

Topology.  

Size: As mentioned above, LANs are restricted in size and usually spread across a range of 1 km of radius.  

Trans mission Technology: It refers to the technology by which data from source is trans mitted to the destinat ion. 

LAN is basically  a Broadcast channel that is shared by all the computers on the network. Data transfer rate in LAN these 

days varies from 10 Mbps to 1000 Mbps (l Giga bits per second) or even more.  

Topology: Most commonly used standard defined for LAN is IEEE 802.3, which is popularly known as Ethernet. It  

defines the types of cables and connectors that can be used. The data transmission rate is 10 Mbps in following 

implementations. Ethernet which uses thick Coaxial cable is called Thick Ethernet and can be used to create a LAN 

segment of 500 meters. It is also called 10Base-5 network.  

Thin Ethernet or 10 Base-2 LAN is implemented through thin coaxial cable and Its LA N segment is limited to 185 

meters. BNC connectors were used in this network.  

These days UTP (Unshielded Twisted Pair) cable is used in more than 90% of the LAN installations. The advantage of this 

implementation is that it is easy to maintain and cost effective. The segment size is limited to 100 meters and computers 

are connected to a central Hub or Switch using star topology.  

10Base-T standard uses UTP category 3 cable and RJ45 connectors. With the UTP CAT5 (category 5) cable and Switch, it 

is possible to achieve a data transfer rate of 100 Mbps in LANs. This implementation is called 100 Base-T.  

5.2.2 Wide Area Networks (WAN)  

A Wide area network (WAN) spans a large geographical area, often a country or continent. WAN is a geographically 

dispersed telecommunications network. For the transmission of data beyond a local area, communication is typically 

achieved by transmitting the data from source to the destination through a network of intermediate switching nodes. These 

switching elements are specialized computers used to connect two or more transmission lines. When data arrives on an 

incoming line, the switching element must choose an outgoing line to forward them on. There is no consensus on the term 

used to represent switching element but Router is much widely used. The term distinguishes a broader telecommunication 

structure from a local area network. A wide area network may be privately owned or rented, but the term usually connotes 

the inclusion of public (shared user) networks. 

In most of the WANs, the network contains numerous cables or telephone lines, each one connecting a pair of routers. If 

two routers that don't share a cable nevertheless wish to communicate, they must do it indirectly via other routers. When a 

packet is sent from one router to another via one or more intermediate routers, the packet is received in its entirety, stored 

there until the required output line is free, and then forwarded.  

 

 



45 

 

 

5.3 INTERNET  

Internet is the world's largest computer network and is described as a network of networks. One of the greatest things about 

the Internet is that nobody really owns it. It is a g lobal collection of networks, both big and small. These networks connect 

together in many different ways to form the single entity that we know as the Internet. In fact, the very name comes from 

this idea of interconnected networks. The term ñThe Internetò was first used in 1982 to refer to the enormous collection of 

inter-connected network that use TCP/IP protocols.  

5.3.1 Concept of Internet  

 

The Internet is a network o f networks that connects users in every country in the world. There are currently over one billion 

Internet users worldwide. The Internet brings the outside world to your desktop in your home or in your office. The 

Internet is a global network made up of thousands of networks that communicate with each other. The Internet offers a 

diverse range of informat ion and ideas, covering almost every topic you can think of. You can also share your knowledge 

and interest with others. 

An individual or organization controls the LAN or private WAN network. The Internet is a conglomerate of networks and 

is not owned by any individual or group. There are, however, several major International organizations that help to manage 

the Internet so that everyone follows the same ru les. 

Whoever wants to connect to Internet must contact Internet Service Provider (ISP). An ISP is a company that provides the 

connections and support to access the Internet. It can also provide additional services such as Email and web hosting. 

You connect to an ISP by using a PC modem to connect to your ISP's modems. Your modem connects to a single modem 

among a bank of modems at your ISP. This is called a dial-up connection. Users within corporations and large 

organizations typically connect to an ISP v ia a h igh-speed link. 

 

Internet Architecture consists of: 

i) User PC  

A Multi -Media PC equipped to send and receive all variety of audio and video. It may include :   

1. Sound Board /Microphone/Speakers  

2. Video/Graphics for 3D graphics, v ideo, playback  

3. Video camera  

4. Vo ice recognition 

 
ii) User's Communication Equipment  

This is the communicat ion equipment located at the User's location(s) to connect the Users' PC(s) to the "Local Loop".It 

may include: 

1. Phone line - Analog Modem  

2. Phone line -ISDN(128K).   

3. Phone Line - DSL (6 MB) ,  

4. Cable Modem (27 MB)  

5. Electric Line (1 MB)  

6. Satellite (400 Kb)  

7. LAN  

8. Routers  

9. Firewalls 
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iii) Local Loop Carrier  

It connects the User location to the ISP's Point of Presence using any of the following:   

1. Communicat ion Lines  

2. Cable.  

3. Satellite  

4. Power line.   

5. Wireless. 

iv) ISP POP  

This is the edge of the ISP's network. Connections from the user are accepted and authenticated here using remote ports.  

v) User Services  

These are the services that most users would use along with Internet Access:  

1. Domain Name.  

2. Email Host   

3. Usenet Newsgroups (NNTP)  

4. Special services such as TELNET, FTP  

5. User Web Hosting  

6. These servers require fast interfaces and large/fast storage.  

vi ) Online Content   

These are the host sites that the user interacts with. It includes:   

1. Web Server platforms  

2. Hosting Farms- Many online resources are hosted at well-connection facilities  

3. These servers require fast interfaces and large/fast storage.  

vii ) Origins of online content   

This is the original "real-world" sources for the online informat ion which may include:  

1. Existing electronic in formation is being connected from legacy systems.  

2. Traditional print resources are being scanned and converted into electronic format  

3. Many types of video and audio programming is being broadcast via the internet.  

4. Internet telephony is growing on the Internet 

viii) ISP Backbone  

The ISP backbone interconnects the ISP's POPs and interconnects the ISP to Other ISP's and online content. It includes :  

1. Backbone Providers  

2. Large Circu its - fiber Circu it carriers  

3. Routers  

4. ATM Switches.  

5. Sonet/SDH Switches.  

6. Gigaswitch  

7. Network Access Points 
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5.3.2 Applications of  Internet  

E-Mail   

It is way to communicate offline between different Internet users. With electronic mail you can send messages to people 

across town, across the country or across the globe instantaneously. It is a concept that is radically reshaping how the world 

communicates. Email goes even further ï you can also send and receive digitized pictures, sounds, and entire computer 

programs, using Internet email as a "carrier". Hundreds of electronic libraries and archives all over the world can be 

accessed using this technique to provide access to their resources. Finally, you can subscribe to mailing lists ï electronic 

equivalents of magazines or newspapers. Except on these magazines, the subscribers can also talk with each other, turning 

the list into a private forum.  

Chat  

Chat or Internet relay Chat is a multi-user, multi channel, real time CHAT. It allows multip le users to take part in the 

conversation. It can be used for market ing, giving production etc., in business sector.  

News Groups  

Many users can communicate and share their views through this internet Service. A newsgroup is a discussion about a 

part icu lar subject cons is ting of notes written to a central Internet site and red istributed through Us enet , a worldwide 

network o f news d iscussion groups. Usenet uses the Network News Transfer Protocol (NNTP). Newsgroups are 

organ ized into subject h ierarch ies, with the first few letters o f the newsgroup name ind icat ing the major s ub ject  

category and sub-categories represented by a subtop ic name. Many subjects have mult ip le levels of subtopics. 

Some major sub ject categories are: news, rec (recreation), soc (society), sci (science), comp (computers ), and many more. 

Users can post to existing news groups, respond to previous posts, and create new newsgroups.  

 

5.3.3 Connecting to the internet  

To prepare the Computer for Internet access and LAN, you would require some informat ion that you can get from the 

Network Adminis t rator. The, Ethernet card can be configured in  the fo llowing steps .  

1. Click on start, select control panel and click on Network or Right click on My Network p laces at desktop and 

select its propert ies. 

 

  
        Des ktop window for windows  2000 professional 

2. This screen informs about the network and dial up connections. Select the one that you want to install.  

  
3. To install local area network, select the icon, a new screen appears: with tile details of the Ethernet card and the 

blank area where components can be installed.  

4. Click on Install button and add the components like Client for Microsoft network, File and printer sharing for 
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Microsoft , NetBE UI protocol. TCP/IP protocol should be added i f you want to access Internet .  

 
Local Area Network connection properties  

 

5. To configure TCP/IP, select it and click on properties. 

 

  
TCP/IP Propert ies 

6. Select obtain IP address automatically i f DHCP has been configured on Windows NT/2000 domain. Otherwise specify 

the IP address manually and subnet mask. If DNS is configured in the network, specify its IP address. DNS is used to 

resolve the names with IP address.  

7. Click on Advanced and Select WINS configuration Tab. As your computer is identified by a name and actually any 

computer needs IP address to connect to network so WINS is required to be configured to resolve names in WIN 

NT/2000 server based network. If WINS is installed in the network, enable WINS resolution by giving  the IP address 

of WINS server.  
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Advanced TCP/IP properties

Once all above details are given, the computer is ready for access through LAN.  

 

To Configure Di al  up connecti on  

 

8. The dial up connect ion should be configured i f you want to access Internet from the computer at your home through 

telephone lines. Select dial up connection option as mentioned in point 2. Network connection wizard will help you in 

creating this dialup connection.  

 

 
 

9. Follow the instructions and give the desired information. Select the connecti on type and click next .  
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10. Now the wizard requ ires to know about the availab ility o f this  connection. Select  the type and click next. 

                  
 

11. Give a name to this dial up connection and click finish to complete. 
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 3. 
 
 
DO IT YOURSELF  
 
Q1. What are the d ifferent  types of topology used in LAN.  

 

Q2. Configure the Ethernet Card after consulting the Network Administrator of an organization.  

 

Q3. Configure the modem Card for Dial up Connection with your ISP.  

 
5.4 SUMMARY  
 
¶ When several computers are interconnected to share the resources, it is called a network.  

¶ There can be several d ifferent  types o f Network like LAN and WAN. 

¶ When this network is confined to  s mall area, i.e., a room, a build ing, it is known as Local Area Network. 

¶ There are several ways by which LAN can be implemented. More than 90% of the organization implementations are 

through UTP cable. 

¶ When the network is spread across a wide area i.e., across the country, in d ifferent  countries, continents, is called 

Wide Area Network.  

¶ Internet  is a network o f networks.  

¶ Different  protocols are used in Internet like www, SM TP (email), FTP, Telnet  (Remote Login). 

¶ LAN Card or Ethernet card can be configured in  consultation with the network administrator of an organization.  

¶ Dialup connection can be configured so that computer can access Internet or email through Internet service provider 

(ISP).  

 
5.7 MODEL ANSWERS  
 
Ans 1 The topologies used in LAN are Bus, Ring, star.  

 

Ans 2 & 3 R f to 5.5  
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CHAPTER 6: WWW AND WEB BROWS ER 

6.0 INT RO DUCTI O N  

The Internet is a collection of computer networks that connects millions of computers around the world. The WWW 

incorporates all he Internet services discussed in last chapter and much more. You Can retrieve documents, view images, 

animation and video, listen to music and sound files, retrieve and transmit voice, and view programs that run on practically 

any software in the world, provided your computer has the hardware and software to do these things.  

Internet browser enables you to connect to the Internet and gain access to the vast storage of information on these 

computers. Whether you are searching for information or having it delivered to your computer, take a look at some of the 

features that make them easy to browse the Internet.  

6.1 OBJE CTI VES  

After completing this lesson you will be able to  

× Explain world wide web 

× Understand different types of Browsers  

× Configure the browser 

× Search websites or web pages 

× Download and search through Internet exp lorer  

 

6.2 WORLD WIDE WEB  

WWW is a system consisting of interlinked hypertext documents, available on Internet.  These web pages can be 

collectively called a website and has a unique name called Website name. These web sites can be accessed on any 

computer connected to Internet using a web browser. The most commonly used web browser is Internet Explorer(IE). The 

web pages or web site may contain text, images, videos and other mult imedia contents and user can navigate between 

them. The English physicist Tim Berners-Lee wrote a proposal in 1989, making a way for so-called WWW (World Wide 

Web). This is why he is called Father of Web. Now he is the director of World Wide Web Consortium. 

A website is a collection of web pages maintained by a single person or organizat ion. In most cases, a website has a distinct 

fully qualified domain name, such as www.yahoo.com. We can classify Websites into three types: 

1. Public 

2. Personal 

3. Intranet 

A public site focuses on a company or an organizat ion. 

A personal site is a site that focuses on an individual. These sites are specifically designed to provide support and services 

to customers of a particu lar product or a range of products. 

An Intranet site provides information about a company, but it makes the informat ion available only to that company's 

employees main ly. 

 

6.3WEB BROWSING SOFTWARE  

A browser is a computer program that resides on your computer enabling you to use the computer to view WWW 

documents and access the Internet taking advantage of text formatt ing, hypertext links, images, sounds, motion, and other 

features. Netscape and Internet Exp lorer are currently the leading "graphical browsers" in the world (meaning they 

facilitate the viewing of graphics such as images and video and more). There are other browsers also like Macweb, Opera. 

Most offer similar features and can be successfully used to retrieve documents and activate different kinds of programs.  

When you log onto the Internet using Netscape or Microsoft's Internet Explorer or some other browser, you are v iewing 

documents on the World Wide Web. It is HTM L and other programming embedded within HTML that makes Hypertext 

possible. Hypertext has the ability to create web pages containing links, which are area in a page or buttons or icons using 

graphics on which user can click mouse button to retrieve another document into the computer. Every document, fi le, site, 

movie, sound file or anything you find on the Web has a unique address called Uniform Resource Locator (URL).  

All b rowsers rely on "plug-ins" to handle the fancier files you find on the Web. Plug-ins are sub-programs stored within a 

browser or elsewhere in your computer especially to support special types of files you may click on. If you click on a link, 

and your computer does not currently have the plug-in needed for the file you clicked on, you are usually prompted with an 

opportunity to get the plug-In. Most plug-ins are free and easy and safe to install on computer, the user has to follow the 

instructions that are given.  

The Screens  

The way in which different browsers differ from each other is in the convenience features they offer for navigating and 

managing the Web and all the URLs you may want to keep track of. Netscape and Internet Explorer both offer the ability 

to e-mail documents, download them to diskette, print them, and keep track of sites visited and important sites you want to 

"bookmark." For most of the purposes, one browser is suffic ient. IE and Netscape are excellent browsers. For a long time, 

Netscape was the mostly used of the two. In the last couple of year, both have become very powerful. Netscape continues 

to offer bookmark capabilit ies that IE's "favorites" cannot match. Most other features are quite similar in both of these 

browsers. The layout of these browsers is organized from top to bottom in the following manner:  

¶ The menu bar (top row, starting with File in  both IE and Nets cape)  

¶ The tool bar buttons (usually second row, starting with Back and Forward, in both IE and Netscape)  

¶ The location or address field, a White box which d isplays the URL of the current document and in which you can 

type the URL of a document you want  to retrieve.  

¶ The document window (the large area in  the center)  

¶ The scroll bars on the right and bottom for moving through the document (appear whenever a document is too tall or 

wide for the screen.  

¶ The progress or status bar chosen appears, and where the URL of a link displays before you cl ick on it.  

 

6.3.1 To Navigate the Web Using IE or Netscape  

1. Click on links or buttons within a document in the document window. Links are the highlighted areas of hypertext in 

the document itself. They will ret rieve other documents. To click on a link, move the mouse over the highlighted area 

and click once.  

2. Back (the first toolbar button) returns to the previous document. Use the Forward toolbar button only after you have 

already backed up to a previous document. It will return you to the document you were viewing before you chose to go 

back. 

3. Go in Netscape and History in IE. It shows you a list of sites you have recently visited. Using them for opening web 

page may be faster than clicking BACK several times.  

4. Home (a little house toolbar button in both IE and Netscape) returns you to the Web Home Page.  
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Gi ving the URL  

If you have the URL (Uniform Resource Locator) of a specific document you want to see, type the URL  into the white 

location or Address box, and press the Enter key. (You will need to highlight and delete the text in that box before you can 

type in a new URL.)  

To Move Through a Document using IE or Netscape  

Click the mouse in the arrows at the ends of the scrollbars on the right (or bottom) side of the document to move through 

the document. You may hold the right mouse button down on the pad in the scroll bars and drag it to move the document as 

well. The space bar key will also take you down through the document, and the backspace key will bring you back up. 

Page Up and Page Down keys or the arrow keys also let you move.  

 

6.3.2 Popular Web Browsers  

Internet Explorer  

Microsoft Internet Explorer enables you to connect to the internet to gain access to the vast stores of information on these 

computers. Subscribe to your favorite sites so that the content is automatically updated whenever you want-daily, weekly, 

or monthly. Internet Exp lorer can download updated Web pages or entire sites in the background while you do other work 

on your computer, or even while you sleep. Then you can browse through them later online, offline, at work, at home, or 

on the road. You can add a Web page to your list of favorites for easy access from the Favorites menu or Exp lorer bar.  

 

With Auto Complete, when you start typing a frequently used URL  in the Address bar, Internet Explorer completes the 

address for you. Using security zones, you can set different layers of security for different areas of the Web to protect your 

computer. With Content Advisor, you can screen out objectionable or offensive content. Once you are set up, take a look at 

some of the things you can do on the Web. From basic browsing and searching, to viewing channels and subscriptions. 

 

 
Figure 6.1 DOEACC Page seen through Internet Explorer  

 

Detailed operations through internet Exp lorer will  be covered in next  sections with screen shots.  

 

Netscape Navigator  

One of the most popular ways people use Netscape is to browse the Web. Navigator, the Netscape component that lets you 

visit web pages, offers many ways to visit web pages and search the Web. When you start Netscape, you see Nav igator, 

your browser. A "What's New" page appears automatically in  the browser window when you first launch Netscape.  

 

After the first launch, you will normally see your home page when you launch Netscape. Unless you choose a home page 

yourself, your home page is chosen by your network or Internet service provider, or you see Netscape's home page. We 

have given www.doeacc.orq.in <http://www.doeacc.org.in> as our home page. 

  
 

Going directly to a URL  

1) Click on File and then on Open Page. Enter a URL in the white box and press Enter to retrieve the document. You 

may also invoke it  using CTRL key + O key.  

2) URL/location/Go To box (white box above the document window) also works to go directly to a URL.  

a) Click over the text of the URL currently in the URL/Location box.  

b) While it is highlighted, type in the new URL and press Enter.  

c) The advantage of using the URL/ locat ion box is that a history of URLs you retrieve is availab le by pressing the gray 

http://www.doeacc.orq.in/
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pop-down arrow at the right end of the URL/location box.  

 

6.3.3 S ETTING UP CONNECTION THRO UGH DIALUP  

1. The fo llowing screens define the process of connect ing through Dialup 

 

 
 

2.  Click on Add in  d ialup s et t ings  area o f Figure above, the fo ll owing screen appears . 

 
 

3. This s creen requ ires to know about the p lace you are in . It als o as ks about the phone syste m. Click on 

drop down arrow of country, you get  fo llow ing screen. 

 
 

4. The screen given below asks about the location and its area code. Click OK to select. 

5. This location can be ed ited with the help of fo llowing screen.  
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6.4 SEARCH ENGINES 

There are three ways to search quickly : from the location Bar, from My Sidebar, and from the Net Search page. A Search 

Engine is a program that searches documents for specified keywords and returns a list of the documents where the 

keywords are found.  

Although search engine is really a general class of programs, the term is often used to specifically describe systems like 

Google,Alta Vista and Excite that enable users to search for documents on the World Wide Web and USENET 

newsgroups. 

Techniques for using a Search Engine 

The best way to learn how to use a search engine is to read the help informat ion and practise. If you want to search for 

words that must be together you can put them within quotation marks. Thus if your first search doesn't find what you want,  

it is a good idea to try different combinations. 

There are two easy ways to narrow the search. 

a. Use a plus (+) sign to indicate you want only Web pages that contain a specific word. 

b. Use a minus (-) sign to indicate you want only Web pages that do not contain a specific word. 

 

6.4.1 POPULAR SEARCH ENGINES 

You can find in formation on the Web in a variety o f ways. When you dick the Search button on the toolbar, the 

Exp lorer bar appears at the left o f the window. It p rov ides access to a number o f search serv ices that o ffer 

different kinds of searching capabilit ies. In Internet Explorer, if you are looking for s ome webs ite, but don 't know 

its URL address, then there are some websites called search engines wh ich helps you to search that website. For 

example, www.yahoo.co m <ht tp :/ /www.yahoo.co m>, www.google.co m <http ://www.google.com>. To s earch 

about  specific topic follow these steps: 

1. Open Internet Exp lorer and Type the URL address of search eng ine webs ite e.g . www.google.com 

<http ://www.google.com> in the Address Bar. The fo llowing screen appears as  shown in the figure below: 

 

  
 

2. Type the desired topic like ñdoeaccò and click on google search. 

3. The new window will open with all the websites related to the topic that you give in the search bar as shown in the 

figure below. Then click on any of the topic. 

 
 
 

6.4.2 ACCESSING THE WEB BROWSER 

Here we are using Microsoft Internet Exp lorer to access World Wide Web and showing you the screen shots.  

Follow the given steps to use this client-based software.  

1. Double-click On the Internet Explorer Icon on the Desktop as shown In the figure below: 

http://www.yahoo.com/
http://www.google.com/
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2. This invokes explorer screen which is shown below. This screen contains the URL in Address Bar and the Home Page 

of given website. The process for setting this screen is given below. 

 
  

3. If you want to make the current website as your Home Page, Click on Tools/Internet Options. The Screen will appear              

as shown in the figure below.  

 
 
To get a desired website, type the URL (name of the website, e.g, www.doeacc.org.in ) of the site in the Address Bar.  

 
6.4.3 USING FAVORITES FOLDER  

The addresses for your favorite websites can be stored in a fo lder so that you can later on ret rieve that address from 

favorites Folder. To add the current  s ite in  your favorites  fo lder, fo llow these steps:  

 

1. Clic k on Favorites on Menu bar, Add to Favorites. This invokes a properties screen as shown in the given figure. 

http://www.doeacc.org.in/
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2. The name of the website automat ically appears in the Name Box. You can click on the icon to make, availab le 

offlin e.  

3. Now click OK to  store this address in  favorites fo lder.  

 

6.4.4 DOWNLOADING WEBPAGES  

When you access a web page, for instance, you are actually downloading the document and all its associated graphics from 

a web server. To download files is to click on the link to the file with your right mouse button and select save to disk from 

the pop ï up box. In  some cases, you will be prompted to save file somewhere on your hard drive or the file may download 

automatically to your desktop, depending on how your browser is configured. Another way to save or download a 

document to a diskette is given below: 

1. From the File menu in IE or Netscape, select Save As. Following dialog box will appear: 

    
 

2. Select Save this to dis k radio button and click OK. It will ask for the folder where th is web page is to be stored 

and the file name. Give folder and file name and click Save.  

The web page is now available in the specified fo lder in your Computer.  

 

6.4.5 PRINTI NG W EB PAGES  

Most browsers have a Print button on the too lbar that lets you print a web page. Click File in the Menu Bar, then Print. 

Select desired options. Click File, then Page setup to alter marg ins, select landscape view and other details. Some web 

pages are divided into multip le sections called frames. You can only print one frame at a time. To print a particular frame, 

first select it by clicking it, then click the Print button or select Print Frame from the File menu.  

 

DO IT YOURSEL F 

Q1. What is a web site?  

Q2.  How web Sites can be accessed?  

Q3. How contents can be searched in Internet?  

 

6.5 SUMMARY  

¶ A web page is an electronic document written in a computer language called HTML.  

¶ A website is one or more web pages that relate to a common theme, such as a person, business, organization, or a 

Subject, such as sports. 

¶ A browser is a computer program that resides on your computer enabling you to use the computer to view WWW 

documents.  


